aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schäfer <gentryx@gmx.de>2013-04-24 23:10:20 +0200
committerAndreas Schäfer <gentryx@gmx.de>2013-04-24 23:10:20 +0200
commit74b9d5e4c5a133f9a2305d2d7128ed201e39db5a (patch)
tree287a6ba9cb380bae06a092896f82c0fb113074ef /dev-util/VampirTrace
parentMerge branch 'master' of https://github.com/gentoo-science/sci (diff)
downloadsci-74b9d5e4c5a133f9a2305d2d7128ed201e39db5a.tar.gz
sci-74b9d5e4c5a133f9a2305d2d7128ed201e39db5a.tar.bz2
sci-74b9d5e4c5a133f9a2305d2d7128ed201e39db5a.zip
added VampirTrace ebuild
Diffstat (limited to 'dev-util/VampirTrace')
-rw-r--r--dev-util/VampirTrace/Manifest1
-rw-r--r--dev-util/VampirTrace/VampirTrace-5.14.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/VampirTrace/Manifest b/dev-util/VampirTrace/Manifest
new file mode 100644
index 000000000..55591bfc9
--- /dev/null
+++ b/dev-util/VampirTrace/Manifest
@@ -0,0 +1 @@
+DIST dcount.php?package=vampirtrace&get=VampirTrace-5.14.3.tar.gz 5956627 SHA256 d3bc18662ee48c9c02de0b5933c52213849cbb79b21a3b4ec786bc21e3126209 SHA512 2b1faa707d12b672ba12b399f6b1c14c8d3cff0b3f961f70b81adb1e5ba69960a217ae228cbacd1ffd3f54aab1b30697ef66748a4fd604e8684910d98041d458 WHIRLPOOL 2bcf401f25f4ed500e92739e36265979cab1c5c0caebb53555caf6f293411b4ac8c542254bc95cad5a81f3458ccb74126580450873ff53a9df3e944f67cb9d48
diff --git a/dev-util/VampirTrace/VampirTrace-5.14.3.ebuild b/dev-util/VampirTrace/VampirTrace-5.14.3.ebuild
new file mode 100644
index 000000000..1e50645f4
--- /dev/null
+++ b/dev-util/VampirTrace/VampirTrace-5.14.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2013-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="VampirTrace is an open source library that allows detailed logging of program execution for parallel applications."
+HOMEPAGE="http://www.tu-dresden.de/die_tu_dresden/zentrale_einrichtungen/zih/forschung/software_werkzeuge_zur_unterstuetzung_von_programmierung_und_optimierung/vampirtrace"
+SRC_URI="http://wwwpub.zih.tu-dresden.de/%7Emlieber/dcount/dcount.php?package=vampirtrace&get=${P}.tar.gz"
+
+SLOT="0"
+LICENSE="vampir"
+KEYWORDS="~amd64"
+IUSE="cuda"
+
+RDEPEND="virtual/mpi"
+
+src_configure() {
+ use cuda && myconf="--with-cuda-dir=/opt/cuda"
+ econf $myconf
+}
+
+src_install() {
+ default
+ # avoid collisions with app-text/lcdf-typetools:
+ mv ${D}/usr/bin/otfinfo ${D}/usr/bin/otfinfo.vampir
+ md ${D}/usr/lib/debug/usr/bin/otfinfo.debug ${D}/usr/lib/debug/usr/bin/otfinfo.vampir.debug
+ # libtool is already installed:
+ rm ${D}/usr/share/libtool
+}