aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-14 19:28:57 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-14 19:28:57 +0100
commitc1a089dced55e876e5bc798e57b4ce5948c5a3fa (patch)
tree2693f8512743014ec6b86d84213bedc6441b0f7c /dev-util/VampirTrace
parentFix $Header to $Id (diff)
downloadsci-c1a089dced55e876e5bc798e57b4ce5948c5a3fa.tar.gz
sci-c1a089dced55e876e5bc798e57b4ce5948c5a3fa.tar.bz2
sci-c1a089dced55e876e5bc798e57b4ce5948c5a3fa.zip
dev-util/VampirTrace: Chop DESCRIPTION to 80 chars
* Bump EAPI to 6 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-util/VampirTrace')
-rw-r--r--dev-util/VampirTrace/VampirTrace-5.14.3.ebuild11
-rw-r--r--dev-util/VampirTrace/VampirTrace-5.14.4.ebuild13
2 files changed, 10 insertions, 14 deletions
diff --git a/dev-util/VampirTrace/VampirTrace-5.14.3.ebuild b/dev-util/VampirTrace/VampirTrace-5.14.3.ebuild
index aa400e747..753c3c08c 100644
--- a/dev-util/VampirTrace/VampirTrace-5.14.3.ebuild
+++ b/dev-util/VampirTrace/VampirTrace-5.14.3.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils cuda
-DESCRIPTION="An open source library that allows detailed logging of program execution for parallel applications"
+DESCRIPTION="Library for detailed logging of program execution for parallel applications"
HOMEPAGE="http://www.tu-dresden.de/die_tu_dresden/zentrale_einrichtungen/zih/forschung/software_werkzeuge_zur_unterstuetzung_von_programmierung_und_optimierung/vampirtrace"
SRC_URI="http://wwwpub.zih.tu-dresden.de/%7Emlieber/dcount/dcount.php?package=vampirtrace&get=${P}.tar.gz"
@@ -30,8 +30,7 @@ src_configure() {
src_install() {
default
# avoid collisions with app-text/lcdf-typetools:
- mv "${D}/usr/bin/otfinfo" "${D}/usr/bin/otfinfo.vampir"
- mv "${D}/usr/lib/debug/usr/bin/otfinfo.debug" "${D}/usr/lib/debug/usr/bin/otfinfo.vampir.debug"
+ mv "${ED}"/usr/bin/otfinfo{,.vampir} || die
# libtool is already installed:
- rm "${D}/usr/share/libtool"
+ rm "${ED}"/usr/share/libtool || die
}
diff --git a/dev-util/VampirTrace/VampirTrace-5.14.4.ebuild b/dev-util/VampirTrace/VampirTrace-5.14.4.ebuild
index 956afcbe0..28a57691a 100644
--- a/dev-util/VampirTrace/VampirTrace-5.14.4.ebuild
+++ b/dev-util/VampirTrace/VampirTrace-5.14.4.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils cuda
MY_PV="${PV}-gpu2"
MY_P="${PN}-${MY_PV}"
-DESCRIPTION="An open source library that allows detailed logging of program execution for parallel applications"
+DESCRIPTION="Library for detailed logging of program execution for parallel applications"
HOMEPAGE="http://tu-dresden.de/die_tu_dresden/zentrale_einrichtungen/zih/forschung/projekte/vampirtrace/accelerator"
SRC_URI="http://wwwpub.zih.tu-dresden.de/~mlieber/dcount/dcount.php?package=gputrace&get=${MY_P}.tar.gz"
@@ -35,10 +35,7 @@ src_configure() {
src_install() {
default
# avoid collisions with app-text/lcdf-typetools:
- mv "${D}/usr/bin/otfinfo" "${D}/usr/bin/otfinfo.vampir" || die
- if [ -e "${D}/usr/lib/debug/usr/bin/otfinfo.debug" ]; then
- mv "${D}/usr/lib/debug/usr/bin/otfinfo.debug" "${D}/usr/lib/debug/usr/bin/otfinfo.vampir.debug" || die
- fi
+ mv "${ED}"/usr/bin/otfinfo{,.vampir} || die
# libtool is already installed:
- rm "${D}/usr/share/libtool" || die
+ rm "${ED}"/usr/share/libtool || die
}