aboutsummaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-14 08:05:16 +0100
committerJustin Lecher <jlec@gentoo.org>2013-01-14 08:05:16 +0100
commit2ffef21ca55b9ed1a555e3114a7df20dbb081785 (patch)
tree686f17df91ca6e923f3b5fb2a1dd7d054719b25c /eclass
parentsci-chemistry/nmrpipe: Version Bump (diff)
parentUpgraded to sci-libs/libsufr-0.4.1.ebuild; added ChangeLog to repo (diff)
downloadsci-2ffef21ca55b9ed1a555e3114a7df20dbb081785.tar.gz
sci-2ffef21ca55b9ed1a555e3114a7df20dbb081785.tar.bz2
sci-2ffef21ca55b9ed1a555e3114a7df20dbb081785.zip
Merge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci
* 'master' of git+ssh://git.overlays.gentoo.org/proj/sci: Upgraded to sci-libs/libsufr-0.4.1.ebuild; added ChangeLog to repo mpi.eclass: fix whitespace
Diffstat (limited to 'eclass')
-rw-r--r--eclass/mpi.eclass12
1 files changed, 6 insertions, 6 deletions
diff --git a/eclass/mpi.eclass b/eclass/mpi.eclass
index 361b0e750..b411ae9ac 100644
--- a/eclass/mpi.eclass
+++ b/eclass/mpi.eclass
@@ -9,11 +9,11 @@ inherit multilib
# Justin Bronder <jsbronder@gentoo.org>
# @BLURB: Common functions for mpi-pkg.eclass and mpi-imp.eclass
-# History:
-# 2009-06-26 (jsbronder): Add ability to require common use flags.
+# History:
+# 2009-06-26 (jsbronder): Add ability to require common use flags.
# Remove dep on eselect-mpi (it's in sys-cluster/empi)
# Use virtual/$class to get imp dep in mpi_pkg_deplist.
-# 2008-11-20 (jsbronder): Initial rewrite from old mpi.eclass
+# 2008-11-20 (jsbronder): Initial rewrite from old mpi.eclass
#####################
@@ -216,7 +216,7 @@ mpi_imp_deplist() {
}
mpi_imp_add_eselect() {
- mpi_classed || return 0
+ mpi_classed || return 0
local c=$(mpi_class)
cp "${FILESDIR}"/${MPI_ESELECT_FILE} ${T}/${c}.eselect || die
sed -i \
@@ -357,7 +357,7 @@ mpi_pkg_fc() { _mpi_pkg_compiler "MPI_FC" "f90 fc"; }
# @USAGE:
# @DESCRIPTION: Adds the correct path(s) to the end of LD_LIBRARY_PATH. Does
# nothing if the build is unclassed.
-mpi_pkg_set_ld_library_path() {
+mpi_pkg_set_ld_library_path() {
if mpi_classed; then
export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:$(_get_eselect_var LD_LIBRARY_PATH)"
fi
@@ -404,7 +404,7 @@ mpi_pkg_set_env() {
# @FUNCTION: mpi_pkg_restore_env
# @USAGE:
# @DESCRIPTION: Attempts to undo the damage done by mpi_pkg_set_env
-mpi_pkg_restore_env() {
+mpi_pkg_restore_env() {
if mpi_classed; then
export CC=$_mpi_oCC
export CXX=$_mpi_oCXX