aboutsummaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorTed Tanberry <ted.tanberry@gmail.com>2015-01-24 21:32:17 +0100
committerTed Tanberry <ted.tanberry@gmail.com>2015-01-24 21:32:17 +0100
commit9300ab0d50abbba92a82d2e5419b512dfb09c788 (patch)
tree5ac925546cd1f7bdaa7eca0b8d745c50703bac66 /eclass
parentFixed various Makefile.am's in order to prevent underlinking of internal libs... (diff)
downloadsci-9300ab0d50abbba92a82d2e5419b512dfb09c788.tar.gz
sci-9300ab0d50abbba92a82d2e5419b512dfb09c788.tar.bz2
sci-9300ab0d50abbba92a82d2e5419b512dfb09c788.zip
Updated all embassy-* packages to build with emboss-6.6.0. emboss.eclass has been updated in order to trigger an autoreconf when a _fix-build-system.patch has been found. Updated the package.mask to reflect the functioning embassy packages.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/emboss.eclass19
1 files changed, 16 insertions, 3 deletions
diff --git a/eclass/emboss.eclass b/eclass/emboss.eclass
index 8ad16d625..0c0bb1206 100644
--- a/eclass/emboss.eclass
+++ b/eclass/emboss.eclass
@@ -45,7 +45,7 @@ case ${EAPI:-0} in
esac
AUTOTOOLS_IN_SOURCE_BUILD=1
-inherit autotools autotools-utils eutils
+inherit autotools autotools-utils eutils flag-o-matic
HOMEPAGE="http://emboss.sourceforge.net/"
LICENSE="LGPL-2 GPL-2"
@@ -66,6 +66,7 @@ DEPEND="
RDEPEND="${DEPEND}"
if [[ ${PN} == embassy-* ]]; then
+ EMBASSY_PACKAGE=yes
# The EMBASSY package name, retrieved from the inheriting ebuild's name
EN=${PN:8}
# The full name and version of the EMBASSY package (excluding the Gentoo
@@ -73,13 +74,14 @@ if [[ ${PN} == embassy-* ]]; then
EF=$(echo ${EN} | tr "[:lower:]" "[:upper:]")-${PV}
: ${EBO_DESCRIPTION:=${EN}}
DESCRIPTION="EMBOSS integrated version of ${EBO_DESCRIPTION}"
- SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/${EF}.tar.gz -> embassy-${EN}-${PV}.tar.gz"
+ SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/${EF}.tar.gz -> embassy-${EN}-${PVR}.tar.gz"
DEPEND+=" >=sci-biology/emboss-6.3.1_p4[mysql=,pdf=,png=,postgres=,static-libs=,X=]"
S="${WORKDIR}"/${EF}
fi
-DOCS="AUTHORS ChangeLog NEWS README"
+DOCS=""
+#DOCS="AUTHORS ChangeLog NEWS README"
# @FUNCTION: emboss_src_prepare
# @DESCRIPTION:
@@ -90,6 +92,12 @@ DOCS="AUTHORS ChangeLog NEWS README"
#
emboss_src_prepare() {
+ if [[ -f "${FILESDIR}"/${P}_fix-build-system.patch ]]; then
+ mv configure.{in,ac} || die
+ epatch "${FILESDIR}"/${P}_fix-build-system.patch
+ AUTOTOOLS_AUTORECONF=1
+ fi
+
[[ -n ${EBO_PATCH} ]] && epatch "${WORKDIR}"/${P}-upstream.patch
[[ -f ${FILESDIR}/${PF}.patch ]] && epatch "${FILESDIR}"/${PF}.patch
@@ -126,6 +134,11 @@ emboss_src_configure() {
--docdir="${EPREFIX}/usr/share/doc/${PF}"
${EBO_EXTRA_ECONF}
)
+
+ if [[ ${EMBASSY_PACKAGE} == yes ]]; then
+ append-cppflags "-I${EPREFIX}/usr/include/emboss"
+ fi
+
autotools-utils_src_configure
}