aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDongxu Li <dongxuli2011@gmail.com>2011-04-30 10:21:55 -0400
committerDongxu Li <dongxuli2011@gmail.com>2011-04-30 10:21:55 -0400
commit0f3ad75f3a451c55c320e8fd2973fd675ce7569a (patch)
tree1c1a5474f5f04352579ed7c71ce7c2579fa40b9d /media-gfx/librecad
parentsci-biology/tablet-bin-1.11.02.18: fixed ebuild for the package and version bump (diff)
downloadsci-0f3ad75f3a451c55c320e8fd2973fd675ce7569a.tar.gz
sci-0f3ad75f3a451c55c320e8fd2973fd675ce7569a.tar.bz2
sci-0f3ad75f3a451c55c320e8fd2973fd675ce7569a.zip
media-gfx/librecad: initial port, #344791
Diffstat (limited to 'media-gfx/librecad')
-rw-r--r--media-gfx/librecad/ChangeLog6
-rw-r--r--media-gfx/librecad/Manifest3
-rw-r--r--media-gfx/librecad/librecad-9999.ebuild39
-rw-r--r--media-gfx/librecad/metadata.xml13
4 files changed, 61 insertions, 0 deletions
diff --git a/media-gfx/librecad/ChangeLog b/media-gfx/librecad/ChangeLog
new file mode 100644
index 000000000..72ff86ab2
--- /dev/null
+++ b/media-gfx/librecad/ChangeLog
@@ -0,0 +1,6 @@
+# ChangeLog for media-gfx/librecad
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header$
+
+ 30 Apr 2011; Dongxu Li <dongxuli2011@gmail.com> +librecad-9999.ebuild:
+ Initial port. #344791, ebuild by Egor Y. Egorov
diff --git a/media-gfx/librecad/Manifest b/media-gfx/librecad/Manifest
new file mode 100644
index 000000000..9697cc6bb
--- /dev/null
+++ b/media-gfx/librecad/Manifest
@@ -0,0 +1,3 @@
+EBUILD librecad-9999.ebuild 904 RMD160 be8b993ed0ad6d412717b32ee47784ae57489ac2 SHA1 84fbe09800c181077b0acd143dd7aaa9f09540f1 SHA256 f2c13ded4d7b3732ddedd7d73959db255717f02fec0bd76042832533b7f419d6
+MISC ChangeLog 240 RMD160 03aa4bb1d07bc59bbf185a84d46343ac456fd2e7 SHA1 29edadf7f46134566ac9bc7c119b5cba7d63525d SHA256 beca7895639d160d99177e1d0fc2e433035a4a672969608bb299b0917d0ec1d9
+MISC metadata.xml 450 RMD160 62a6501cecfe47078279b48be9b1c658d40e59f9 SHA1 c4ea83204f0d636b89b362f43aa2f5f487b9d9c7 SHA256 891d496161866e9f329036a1a953bd667d7be70de7cb1da41eadbb4be21c7df8
diff --git a/media-gfx/librecad/librecad-9999.ebuild b/media-gfx/librecad/librecad-9999.ebuild
new file mode 100644
index 000000000..bd6a50913
--- /dev/null
+++ b/media-gfx/librecad/librecad-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: caduntu-9999.ebuild $
+
+EAPI="2"
+
+inherit qt4-r2 subversion
+
+DESCRIPTION="An generic 2D CAD program"
+HOMEPAGE="http://www.librecad.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+ESVN_REPO_URI=https://librecad.svn.sourceforge.net/svnroot/librecad/trunk/
+ESVN_RESTRICT=export
+
+RDEPEND="x11-libs/qt-gui[qt3support]"
+DEPEND="${RDEPEND}"
+
+src_unpack()
+{
+ subversion_src_unpack || die
+ cd "$(subversion__get_wc_path "${ESVN_REPO_URI}")"
+ rsync -rlpgo . "${S}" || die "${ESVN}: can't export to ${S}."
+}
+
+src_install()
+{
+ dobin unix/librecad || die
+ insinto /usr/share/"${PN}"
+ doins -r unix/resources/* || die
+ if use doc ; then
+ dohtml -r support/doc/* || die
+ fi
+ doicon res/main/"${PN}".png || die
+ make_desktop_entry "${PN}" LibreCAD "${PN}.png" Graphics || die
+}
diff --git a/media-gfx/librecad/metadata.xml b/media-gfx/librecad/metadata.xml
new file mode 100644
index 000000000..684d04155
--- /dev/null
+++ b/media-gfx/librecad/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>dongxuli2011@gmail.com</email>
+</maintainer>
+<longdescription lang="en">
+ LibreCAD is a 2D CAD drawing tool based on the community edition of QCad
+ (www.qcad.org). LibreCAD has been re-structured and ported to qt4 and works
+ natively cross platform.
+</longdescription>
+</pkgmetadata>