aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDongxu Li <dongxuli2011@gmail.com>2012-02-05 07:52:23 -0500
committerDongxu Li <dongxuli2011@gmail.com>2012-02-05 07:52:23 -0500
commitebe763f0b7670f02d1e654a68f8c5018a2407b53 (patch)
tree899c9d6ba2fe30fb99f933948c755f7527684e44 /media-gfx
parentadded openmp support (diff)
downloadsci-ebe763f0b7670f02d1e654a68f8c5018a2407b53.tar.gz
sci-ebe763f0b7670f02d1e654a68f8c5018a2407b53.tar.bz2
sci-ebe763f0b7670f02d1e654a68f8c5018a2407b53.zip
media-gfx/librecad: version bumped to 1.0.1
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/librecad/ChangeLog3
-rw-r--r--media-gfx/librecad/Manifest1
-rw-r--r--media-gfx/librecad/librecad-1.0.1.ebuild42
3 files changed, 46 insertions, 0 deletions
diff --git a/media-gfx/librecad/ChangeLog b/media-gfx/librecad/ChangeLog
index 0605e3880..ccf81327e 100644
--- a/media-gfx/librecad/ChangeLog
+++ b/media-gfx/librecad/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header$
+ 5 Feb 2012; Dongxu Li <dongxuli2011@gmail.com> +librecad-1.0.1.ebuild
+ Version bumped to 1.0.1
+
14 Dec 2011; Dongxu Li <dongxuli2011@gmail.com> +librecad-1.0.0.ebuild -librecad-1.0.0_rc3.ebuild, -librecad-1.0.0_rc4.ebuild:
Version bumped to 1.0.0
diff --git a/media-gfx/librecad/Manifest b/media-gfx/librecad/Manifest
index d96f650b7..ecd7a7505 100644
--- a/media-gfx/librecad/Manifest
+++ b/media-gfx/librecad/Manifest
@@ -1,2 +1,3 @@
DIST librecad-1.0.0.tar.gz 4714351 RMD160 834f24dcf5293af183ffaf4734f00d48e7641bc5 SHA1 67f50b230ec41c0786129a7b269aa11664bc3282 SHA256 89b1f8227f0f8df30584958924cc8ad3eb61c751b4b83ef80effa3e4b79f3168
+DIST librecad-1.0.1.tar.gz 4717733 SHA256 218d58d66c3b665c0998b79dda2255985c75f5c150611e70c2e7c1b87655c85b SHA512 72ede3094c4f5e8167e67aace2ebc68334fc88b873c11980b345ea1416dc2659673ef4b8867fd00e61593915eae747e8098896fd1c74a5d85f2c85aa875e1cf2 WHIRLPOOL 5189e77dc465e4776b7b536566f359a8b72da802d9080701b33975e585ba63c70dd67006df6f5f857c37d7d36ddc9cf36c9485ebe9e826d6be85c62c3cf4fb26
DIST librecad-2.0.0_alpha1.tar.gz 13771736 RMD160 dd52fdd3a71927a84e8ddc0d64b70fc4b5c910d7 SHA1 043ad1ebbae8c98c14f96e8fa0d3c8f48f0d161b SHA256 a7355cfddb0a51eac38da5b0b764848cc11981669c3486447be89251846daecb
diff --git a/media-gfx/librecad/librecad-1.0.1.ebuild b/media-gfx/librecad/librecad-1.0.1.ebuild
new file mode 100644
index 000000000..81ae616e5
--- /dev/null
+++ b/media-gfx/librecad/librecad-1.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit qt4-r2
+
+DESCRIPTION="An generic 2D CAD program"
+HOMEPAGE="http://www.librecad.org/"
+SRC_URI="https://nodeload.github.com/LibreCAD/LibreCAD/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="
+ x11-libs/qt-gui[qt3support]
+ x11-libs/qt-assistant:4
+ x11-libs/qt-qt3support:4"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ mv * ${P}
+}
+
+src_prepare() {
+sed -i -e "s:\\\$\+system(git describe --tags):1.0.0:" "${PN}.pro"
+}
+
+src_install() {
+ dobin unix/librecad || die
+ insinto /usr/share/"${PN}"
+ doins -r unix/resources/* || die
+ if use doc ; then
+ dohtml -r support/doc/*
+ fi
+ doicon res/main/"${PN}".png
+ make_desktop_entry "${PN}" LibreCAD "${PN}.png" Graphics
+}