aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-11-23 15:32:24 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2016-11-23 15:32:24 +0100
commit03ed085e92f2e8af8dfc3dc83f6da1c3470a7e16 (patch)
treee6c5d8c76666fde6e0d123c7a6f6b65c58959fc8 /media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch
parentmedia-libs/glbinding: New packages, ebuild written by me (diff)
downloadsci-03ed085e92f2e8af8dfc3dc83f6da1c3470a7e16.tar.gz
sci-03ed085e92f2e8af8dfc3dc83f6da1c3470a7e16.tar.bz2
sci-03ed085e92f2e8af8dfc3dc83f6da1c3470a7e16.zip
media-libs/glbinding: Update CMakeLists patch
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch')
-rw-r--r--media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch16
1 files changed, 3 insertions, 13 deletions
diff --git a/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch b/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch
index 080cb7fae..8c4b50577 100644
--- a/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch
+++ b/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch
@@ -1,14 +1,5 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -103,7 +103,7 @@ endif()
- if(UNIX AND SYSTEM_DIR_INSTALL)
- # Install into the system (/usr/bin or /usr/local/bin)
- set(INSTALL_ROOT "share/${project}") # /usr/[local]/share/<project>
-- set(INSTALL_CMAKE "share/${project}/cmake") # /usr/[local]/share/<project>/cmake
-+ set(INSTALL_CMAKE "lib/cmake") # /usr/[local]/lib/cmake
- set(INSTALL_EXAMPLES "share/${project}") # /usr/[local]/share/<project>
- set(INSTALL_DATA "share/${project}") # /usr/[local]/share/<project>
- set(INSTALL_BIN "bin") # /usr/[local]/bin
@@ -159,16 +159,8 @@ add_subdirectory(deploy)
# Deployment (global project files)
#
@@ -17,13 +8,12 @@
-install(FILES "${PROJECT_BINARY_DIR}/VERSION" DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
-
# Install cmake find script for the project
--install(FILES ${META_PROJECT_NAME}-config.cmake DESTINATION ${INSTALL_ROOT} COMPONENT dev)
--
+ install(FILES ${META_PROJECT_NAME}-config.cmake DESTINATION ${INSTALL_ROOT} COMPONENT dev)
+
-# Install the project meta files
-install(FILES AUTHORS DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
-install(FILES LICENSE DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
-install(FILES README.md DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
-+install(FILES ${META_PROJECT_NAME}-config.cmake DESTINATION ${INSTALL_LIB}/cmake/${project} COMPONENT dev)
-
+-
# Install runtime data
install(DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION ${INSTALL_DATA} COMPONENT examples_data)