aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-11-23 13:26:43 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2016-11-23 13:26:43 +0100
commitb8c8ce2ed9b9bd422a697ed1c897d8fc80c3e637 (patch)
tree997b0823713504f7fe08073139a5199cb6cdf6ba /media-libs/glbinding/files
parentMerge pull request #695 from timeraider4u/giac-fix (diff)
downloadsci-b8c8ce2ed9b9bd422a697ed1c897d8fc80c3e637.tar.gz
sci-b8c8ce2ed9b9bd422a697ed1c897d8fc80c3e637.tar.bz2
sci-b8c8ce2ed9b9bd422a697ed1c897d8fc80c3e637.zip
media-libs/glbinding: New packages, ebuild written by me
Required by up-to-date arrayfire/forge versions Package-Manager: portage-2.3.0
Diffstat (limited to 'media-libs/glbinding/files')
-rw-r--r--media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch b/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch
new file mode 100644
index 000000000..080cb7fae
--- /dev/null
+++ b/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch
@@ -0,0 +1,29 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -103,7 +103,7 @@ endif()
+ if(UNIX AND SYSTEM_DIR_INSTALL)
+ # Install into the system (/usr/bin or /usr/local/bin)
+ set(INSTALL_ROOT "share/${project}") # /usr/[local]/share/<project>
+- set(INSTALL_CMAKE "share/${project}/cmake") # /usr/[local]/share/<project>/cmake
++ set(INSTALL_CMAKE "lib/cmake") # /usr/[local]/lib/cmake
+ set(INSTALL_EXAMPLES "share/${project}") # /usr/[local]/share/<project>
+ set(INSTALL_DATA "share/${project}") # /usr/[local]/share/<project>
+ set(INSTALL_BIN "bin") # /usr/[local]/bin
+@@ -159,16 +159,8 @@ add_subdirectory(deploy)
+ # Deployment (global project files)
+ #
+
+-# Install version file
+-install(FILES "${PROJECT_BINARY_DIR}/VERSION" DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
+-
+ # Install cmake find script for the project
+-install(FILES ${META_PROJECT_NAME}-config.cmake DESTINATION ${INSTALL_ROOT} COMPONENT dev)
+-
+-# Install the project meta files
+-install(FILES AUTHORS DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
+-install(FILES LICENSE DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
+-install(FILES README.md DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
++install(FILES ${META_PROJECT_NAME}-config.cmake DESTINATION ${INSTALL_LIB}/cmake/${project} COMPONENT dev)
+
+ # Install runtime data
+ install(DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION ${INSTALL_DATA} COMPONENT examples_data)