aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-02-21 17:22:52 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-21 17:30:32 +0100
commit5eae9bd45721dfd5ba1a9092195993b94d15f687 (patch)
tree890c7c384223e7044941f317c5546085dd6b108f /net-misc/cernbox-client
parentsci-mathematics/ltl2ba: Port to EAPI 7 (diff)
downloadsci-5eae9bd45721dfd5ba1a9092195993b94d15f687.tar.gz
sci-5eae9bd45721dfd5ba1a9092195993b94d15f687.tar.bz2
sci-5eae9bd45721dfd5ba1a9092195993b94d15f687.zip
net-misc/cernbox-client: Bump to 2.7.6.3261.
Follows new version of net-misc/owncloud-client. Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'net-misc/cernbox-client')
-rw-r--r--net-misc/cernbox-client/Manifest1
-rw-r--r--net-misc/cernbox-client/cernbox-client-2.7.6.3261.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/cernbox-client/Manifest b/net-misc/cernbox-client/Manifest
index 2e801296d..b71281eae 100644
--- a/net-misc/cernbox-client/Manifest
+++ b/net-misc/cernbox-client/Manifest
@@ -1,3 +1,4 @@
DIST cernbox-client-2.7.1-2596.src.rpm 15434250 BLAKE2B 3ef3fcc4010b3f292aee9b6bba7b5f9a72e4fbca1236e1e85e6523cd4e38d980fe4542c5f019647a19040be64628159651630a61ee8894cb7bcf4b69d342ccd0 SHA512 e329b84fc7aa62068f934bf8a9f47432709094adc618274c1b8ddbf7331094cb71b6208d3a777150ee426141301e0279cb219d65b123335f2e198a9b87980e5d
DIST ownCloud-2.7.4.2934.tar.xz 14151708 BLAKE2B ad6f3d827a2fdcead6fdc2514696e8fbdb75b2d365c9a09602b95b24c669695e3693167f5da305e27e6fb2266f106b50c578def1d1518730926a10f640defbd9 SHA512 7e04d987751d0b8e29fbe8ba8ae58f38fabd7f5007f7508d001532e595b00f58cce487b1d180928154286ffd6b01db1e6ca0407f7d675e8b101ec4ae8414f2a6
DIST ownCloud-2.7.5.3180.tar.xz 14154036 BLAKE2B ebee57568b917c1c7dec8f41f172caf53d0bfe4eae5e24ec5c9adbf656bf667769b0ed341a13a899ff6a04cd779d92b145736dce5a4e72055d306b2f08e0a902 SHA512 9e788341c45753eb2d2c62d252cf453259474689fd7d498147e0f4548a9038bd44bdca1539f9617d383853f8f9ca2f24c575667fb96e2a1a4ceec30195d257c2
+DIST ownCloud-2.7.6.3261.tar.xz 14237692 BLAKE2B 914b069b10fa2f169677768e1578c5b8569836eb574889c72c0ea1ca3e16e6b7c65bcdd1f4a5ce4259eab6ec56110e3b45799d010921e47c7f64ccfd0ed545bf SHA512 1f647dd0b33472e31719651fa22b5864867d98fa1e2f11f9eadb6ce15382f5f97ac49d726af079716b6fac573367485a6f11a5b2e5e5c95d4d063f6caab51dcd
diff --git a/net-misc/cernbox-client/cernbox-client-2.7.6.3261.ebuild b/net-misc/cernbox-client/cernbox-client-2.7.6.3261.ebuild
new file mode 100644
index 000000000..2eb01cf8e
--- /dev/null
+++ b/net-misc/cernbox-client/cernbox-client-2.7.6.3261.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake rpm xdg
+
+DESCRIPTION="Synchronize files from CERNBox EOS with your computer"
+
+# Origin is classic owncloud-client, branded for CERN during compilation.
+ORIGIN_PN="ownCloud"
+BRANDED_P="cernbox"
+BRANDED_PV="2.7.1"
+BRANDED_REL="2596"
+HOMEPAGE="https://cernbox.cern.ch/"
+SRC_URI="http://download.owncloud.com/desktop/${ORIGIN_PN}/stable/${PV}/source/${ORIGIN_PN}-${PV}.tar.xz
+ https://cernbox.cern.ch/cernbox/doc/Linux/repo/CentOS_7/src/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm
+ https://cern.ch/ofreyerm/gentoo/cernbox/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm"
+
+LICENSE="CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc dolphin gnome-keyring nautilus test"
+
+COMMON_DEPEND=">=dev-db/sqlite-3.4:3
+ dev-libs/qtkeychain[gnome-keyring?,qt5(+)]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-fs/inotify-tools
+ dolphin? (
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/kio:5
+ )
+ nautilus? ( dev-python/nautilus-python )"
+
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/linguist-tools:5
+ kde-frameworks/extra-cmake-modules
+ doc? (
+ dev-python/sphinx
+ dev-tex/latexmk
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )
+ test? (
+ dev-util/cmocka
+ dev-qt/qttest:5
+ )"
+
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${ORIGIN_PN}-${PV}
+
+src_unpack() {
+ rpm_src_unpack ${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm || die "failed to extract branding RPM"
+ mv ${PN%-*}-${BRANDED_PV}.${BRANDED_REL}/branding "${S}" || die "failed to extract branding"
+}
+
+src_prepare() {
+ # Keep tests in ${T}
+ sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die
+
+ if ! use nautilus; then
+ pushd shell_integration > /dev/null || die
+ cmake_comment_add_subdirectory nautilus
+ popd > /dev/null || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DCMAKE_DISABLE_FIND_PACKAGE_Sphinx=$(usex !doc)
+ -DBUILD_SHELL_INTEGRATION_DOLPHIN=$(usex dolphin)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if ! use doc ; then
+ elog "Documentation and man pages not installed"
+ elog "Enable doc USE-flag to generate them"
+ fi
+ xdg_pkg_postinst
+}