aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-13 08:59:14 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-13 08:59:14 +0200
commit14a67069ad965ee75541aa5e9e974fe7ed9925f8 (patch)
treec99acff159a7bae471f3b497a0faa29315a06040 /sci-astronomy/bpz
parentdev-tcltk/img_rotate: Bump to EAPI=5 and fix license (diff)
downloadsci-14a67069ad965ee75541aa5e9e974fe7ed9925f8.tar.gz
sci-14a67069ad965ee75541aa5e9e974fe7ed9925f8.tar.bz2
sci-14a67069ad965ee75541aa5e9e974fe7ed9925f8.zip
sci-astronomy/bpz: Bump to EAPI=5 and python-single-r1; restrict license
Package-Manager: portage-2.2.0_alpha179
Diffstat (limited to 'sci-astronomy/bpz')
-rw-r--r--sci-astronomy/bpz/ChangeLog5
-rw-r--r--sci-astronomy/bpz/bpz-1.99.3.ebuild57
-rw-r--r--sci-astronomy/bpz/metadata.xml4
3 files changed, 36 insertions, 30 deletions
diff --git a/sci-astronomy/bpz/ChangeLog b/sci-astronomy/bpz/ChangeLog
index fd50d6ff3..ae660512e 100644
--- a/sci-astronomy/bpz/ChangeLog
+++ b/sci-astronomy/bpz/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-astronomy/bpz
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 13 Jun 2013; Justin Lecher <jlec@gentoo.org> bpz-1.99.3.ebuild, metadata.xml:
+ Bump to EAPI=5 and python-single-r1; restrict license
+
*bpz-1.99.3 (10 May 2012)
10 May 2012; SĂ©bastien Fabbro <bicatali@gentoo.org> +bpz-1.99.3.ebuild,
diff --git a/sci-astronomy/bpz/bpz-1.99.3.ebuild b/sci-astronomy/bpz/bpz-1.99.3.ebuild
index 8eb0fc83a..758623960 100644
--- a/sci-astronomy/bpz/bpz-1.99.3.ebuild
+++ b/sci-astronomy/bpz/bpz-1.99.3.ebuild
@@ -1,55 +1,58 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3*"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit python
+inherit python-single-r1
DESCRIPTION="Bayesian Photometric Redshifts"
HOMEPAGE="http://www.its.caltech.edu/~coe/BPZ/"
SRC_URI="${HOMEPAGE}/${P}.tar.gz"
-LICENSE="as-is"
+LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
-RDEPEND="dev-python/numpy
- || ( dev-python/matplotlib dev-python/python-biggles )"
-DEPEND="test? ( ${RDEPEND} )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ || (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/python-biggles[${PYTHON_USEDEP}]
+ )"
+DEPEND="${PYTHON_DEPS}
+ test? ( ${RDEPEND} )"
src_prepare() {
- sed -i -e 's/TkAgg/Agg/g' bpz.py plots/probplot.py plots/coeplot.py
+ sed \
+ -e 's/TkAgg/Agg/g' \
+ -i bpz.py plots/probplot.py plots/coeplot.py || die
}
src_test() {
cd test
- testing() {
- export BPZPATH="${S}" PYTHONPATH="${S}"
- "$(PYTHON)" ../bpz.py UDFtest.cat -INTERP 2
- "$(PYTHON)" ../bpzfinalize.py UDFtest
- "$(PYTHON)" ../plots/webpage.py UDFtest
- }
- python_execute_function testing
+ export BPZPATH="${S}" PYTHONPATH="${S}"
+ ${EPYTHON} ../bpz.py UDFtest.cat -INTERP 2 || die
+ ${EPYTHON} ../bpzfinalize.py UDFtest || die
+ ${EPYTHON} ../plots/webpage.py UDFtest || die
}
src_install() {
insinto /usr/share/bpz
doins -r FILTER SED AB
- installation() {
- insinto $(python_get_sitedir)/bpz
- doins -r *.py plots
- }
- python_execute_function installation
+ python_moduleinto ${PN}
+ python_domodule *.py plots
+
cat <<-EOF > bpz
#!$(type -P sh)
- sitedir=\$(python -c 'from distutils.sysconfig import get_python_lib; print(get_python_lib())')
- BPZPATH=${EPREFIX}/usr/share/bpz python \${sitedir}/bpz/bpz.py \$@
+ sitedir=$(python_get_sitedir)
+ BPZPATH="${EPREFIX}"/usr/share/bpz ${EPYTHON} \${sitedir}/bpz/bpz.py \$@
EOF
- exeinto /usr/bin
- doexe bpz
+
+ dobin bpz
}
diff --git a/sci-astronomy/bpz/metadata.xml b/sci-astronomy/bpz/metadata.xml
index 1cefed3d5..c9265864a 100644
--- a/sci-astronomy/bpz/metadata.xml
+++ b/sci-astronomy/bpz/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-astronomy</herd>
-<longdescription lang="en">
+ <herd>sci-astronomy</herd>
+ <longdescription lang="en">
Bayesian Photometric Redshifts is a method to infere photometric
redshifts of galaxies.
</longdescription>