aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-23 12:34:09 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-23 12:34:09 +0200
commit31948f21ddfb503f0c25d80ee1f38ba348fbc69d (patch)
tree3e4471e1cb6b889add274c3feb0060c3bc935892 /sci-astronomy/missfits
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-31948f21ddfb503f0c25d80ee1f38ba348fbc69d.tar.gz
sci-31948f21ddfb503f0c25d80ee1f38ba348fbc69d.tar.bz2
sci-31948f21ddfb503f0c25d80ee1f38ba348fbc69d.zip
Drop unnecessary die from emake
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-astronomy/missfits')
-rw-r--r--[l---------]sci-astronomy/missfits/missfits-2.8.0.ebuild34
1 files changed, 33 insertions, 1 deletions
diff --git a/sci-astronomy/missfits/missfits-2.8.0.ebuild b/sci-astronomy/missfits/missfits-2.8.0.ebuild
index b8cfc9035..19b75a881 120000..100644
--- a/sci-astronomy/missfits/missfits-2.8.0.ebuild
+++ b/sci-astronomy/missfits/missfits-2.8.0.ebuild
@@ -1 +1,33 @@
-missfits-9999.ebuild \ No newline at end of file
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit subversion
+ ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ SRC_URI=""
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit autotools-utils
+
+DESCRIPTION="Performs basic maintenance and packaging tasks on FITS files"
+HOMEPAGE="http://www.astromatic.net/software/missfits/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_install () {
+ autotools-utils_src_install
+ use doc && dodoc doc/*
+}