aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-23 12:34:09 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-23 12:34:09 +0200
commit31948f21ddfb503f0c25d80ee1f38ba348fbc69d (patch)
tree3e4471e1cb6b889add274c3feb0060c3bc935892 /sci-astronomy/psfex
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-31948f21ddfb503f0c25d80ee1f38ba348fbc69d.tar.gz
sci-31948f21ddfb503f0c25d80ee1f38ba348fbc69d.tar.bz2
sci-31948f21ddfb503f0c25d80ee1f38ba348fbc69d.zip
Drop unnecessary die from emake
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-astronomy/psfex')
-rw-r--r--[l---------]sci-astronomy/psfex/psfex-3.17.0.ebuild71
-rw-r--r--[l---------]sci-astronomy/psfex/psfex-3.9.1.ebuild71
2 files changed, 140 insertions, 2 deletions
diff --git a/sci-astronomy/psfex/psfex-3.17.0.ebuild b/sci-astronomy/psfex/psfex-3.17.0.ebuild
index 1942f52c3..db23a2197 120000..100644
--- a/sci-astronomy/psfex/psfex-3.17.0.ebuild
+++ b/sci-astronomy/psfex/psfex-3.17.0.ebuild
@@ -1 +1,70 @@
-psfex-9999.ebuild \ No newline at end of file
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit subversion
+ ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Extracts models of the Point Spread Function from FITS images"
+HOMEPAGE="http://www.astromatic.net/software/psfex"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="doc threads plplot"
+
+RDEPEND="
+ sci-libs/atlas[lapack,threads=]
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local mycblas=atlcblas myclapack=atlclapack
+ if use threads; then
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && \
+ mycblas=ptcblas
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] &&
+ myclapack=ptclapack
+ fi
+ # fix the configure and not the acx_atlas.m4. the eautoreconf will
+ # produce a configure giving a wrong install Makefile target (to fix)
+ sed -i \
+ -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s/-llapack/-l${myclapack}/g" \
+ -e "s/\(lapack_lib=\).*/\1${myclapack}/g" \
+ -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
+ acx_atlas.m4 || die
+
+ # fix for newer plplot
+ sed -i -e 's/plcol(/plcol0(/g' src/cplot.c || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-atlas-incdir="${EPREFIX}/usr/include/atlas"
+ $(use_enable plplot)
+ $(use_enable threads)
+ )
+ autotools-utils_src_configure
+}
+
+src_install () {
+ autotools-utils_src_install
+ use doc && dodoc doc/*
+}
diff --git a/sci-astronomy/psfex/psfex-3.9.1.ebuild b/sci-astronomy/psfex/psfex-3.9.1.ebuild
index 1942f52c3..db23a2197 120000..100644
--- a/sci-astronomy/psfex/psfex-3.9.1.ebuild
+++ b/sci-astronomy/psfex/psfex-3.9.1.ebuild
@@ -1 +1,70 @@
-psfex-9999.ebuild \ No newline at end of file
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit subversion
+ ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Extracts models of the Point Spread Function from FITS images"
+HOMEPAGE="http://www.astromatic.net/software/psfex"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="doc threads plplot"
+
+RDEPEND="
+ sci-libs/atlas[lapack,threads=]
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local mycblas=atlcblas myclapack=atlclapack
+ if use threads; then
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && \
+ mycblas=ptcblas
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] &&
+ myclapack=ptclapack
+ fi
+ # fix the configure and not the acx_atlas.m4. the eautoreconf will
+ # produce a configure giving a wrong install Makefile target (to fix)
+ sed -i \
+ -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s/-llapack/-l${myclapack}/g" \
+ -e "s/\(lapack_lib=\).*/\1${myclapack}/g" \
+ -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
+ acx_atlas.m4 || die
+
+ # fix for newer plplot
+ sed -i -e 's/plcol(/plcol0(/g' src/cplot.c || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-atlas-incdir="${EPREFIX}/usr/include/atlas"
+ $(use_enable plplot)
+ $(use_enable threads)
+ )
+ autotools-utils_src_configure
+}
+
+src_install () {
+ autotools-utils_src_install
+ use doc && dodoc doc/*
+}