aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2011-11-28 21:35:17 +0000
committerSébastien Fabbro <sebfabbro@gmail.com>2011-11-28 21:35:17 +0000
commitf5d0d9fcf03e7f67c4815305cd00b2cd738f082f (patch)
tree129163d48dd19cafeee10ef91a4e80dd1caa66b0 /sci-astronomy/psfex
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-f5d0d9fcf03e7f67c4815305cd00b2cd738f082f.tar.gz
sci-f5d0d9fcf03e7f67c4815305cd00b2cd738f082f.tar.bz2
sci-f5d0d9fcf03e7f67c4815305cd00b2cd738f082f.zip
fixed astromatic packages for recent ATLAS
Diffstat (limited to 'sci-astronomy/psfex')
-rw-r--r--sci-astronomy/psfex/ChangeLog6
-rw-r--r--sci-astronomy/psfex/Manifest4
-rw-r--r--sci-astronomy/psfex/psfex-3.9.1-r1.ebuild50
-rw-r--r--sci-astronomy/psfex/psfex-3.9.1.ebuild45
4 files changed, 58 insertions, 47 deletions
diff --git a/sci-astronomy/psfex/ChangeLog b/sci-astronomy/psfex/ChangeLog
index 194a9b99f..24df27043 100644
--- a/sci-astronomy/psfex/ChangeLog
+++ b/sci-astronomy/psfex/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*psfex-3.9.1-r1 (28 Nov 2011)
+
+ 28 Nov 2011; Sébastien Fabbro <bicatali@gentoo.org> -psfex-3.9.1.ebuild,
+ +psfex-3.9.1-r1.ebuild:
+ Fixed for recent ATLAS. Switch to EAPI4
+
04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Switched herd to sci-astronomy
diff --git a/sci-astronomy/psfex/Manifest b/sci-astronomy/psfex/Manifest
index 9620f0611..026983a33 100644
--- a/sci-astronomy/psfex/Manifest
+++ b/sci-astronomy/psfex/Manifest
@@ -1,4 +1,4 @@
DIST psfex-3.9.1.tar.gz 2364495 RMD160 54c1a32c7f9305a91b973a974c4ae527a4dc3143 SHA1 af164b4e3d1bf61cdd738e8c52730f8564460ae0 SHA256 1758a1a40166ef59475d8fab6abda33ca0ed0a837531ff7ad577d8bce4e511f7
-EBUILD psfex-3.9.1.ebuild 1183 RMD160 26f4f8c2c4e6e6bee033972d051f5ca949a58877 SHA1 88f82e87f8258be728318d1930dfcf93cec51022 SHA256 afe364cee799aabbe1a474fbd62f88db3288f7078292be05965f437e81083d55
-MISC ChangeLog 223 RMD160 d0b003facb024aa6fdd256e22e4bc195fb869fad SHA1 88423e194987deee94f09e7bf83a2108fb5cdaf2 SHA256 e54455e8fe6b6c783abcba8ee9911786d19e3434881f11652617a007dd6d0036
+EBUILD psfex-3.9.1-r1.ebuild 1350 RMD160 823380233c4decbefbb8c2dace96dfc218aa7bb5 SHA1 aa65bacadc4b1db078e3d8ffbb680cfc8047728e SHA256 7c6a36089c831ecac4ad54a227ab69fc5b054e7d73c82b4ea77caf39fed69065
+MISC ChangeLog 399 RMD160 6d6be363a1d1492134ac80cb1bd21117e6b53bad SHA1 b2f0e87c7e0243ff95f200569e9b9ddf85cc7044 SHA256 e34cfb8188b6509de73cfe000e375c79cf1737fcc8698699d59dc51d1087930a
MISC metadata.xml 618 RMD160 4457a863e2920a162d35f06cb54131569b7a1570 SHA1 39b4dbb51a1b04df0638bbb35404970544d91531 SHA256 5d67566a70b08931f4df71183ef8c69d237af0c54d8544547fc8bd0712160e5f
diff --git a/sci-astronomy/psfex/psfex-3.9.1-r1.ebuild b/sci-astronomy/psfex/psfex-3.9.1-r1.ebuild
new file mode 100644
index 000000000..d94b5c3f8
--- /dev/null
+++ b/sci-astronomy/psfex/psfex-3.9.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Extracts models of the Point Spread Function from FITS images"
+HOMEPAGE="http://www.astromatic.net/software/psfex"
+SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc plplot threads"
+
+RDEPEND="virtual/cblas
+ sci-libs/atlas
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ local mycblas=atlcblas myclapack=atlclapack
+ if use threads; then
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && mycblas=ptcblas
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] && myclapack=ptclapack
+ fi
+ # fix the configure and not the acx_atlas.m4. the eautoreconf will
+ # produce a configure giving a wrong install Makefile target (to fix)
+ sed -i \
+ -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s/-llapack/-l${myclapack}/g" \
+ -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
+ configure || die "sed acx_atlas.m4 failed"
+}
+
+src_configure() {
+ econf \
+ --with-atlas-incdir="${EROOT}/usr/include/atlas" \
+ $(use_with plplot) \
+ $(use_enable threads)
+}
+
+src_install () {
+ default
+ use doc && dodoc doc/*.pdf
+}
diff --git a/sci-astronomy/psfex/psfex-3.9.1.ebuild b/sci-astronomy/psfex/psfex-3.9.1.ebuild
deleted file mode 100644
index 3530ea969..000000000
--- a/sci-astronomy/psfex/psfex-3.9.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/scamp/scamp-1.7.0.ebuild,v 1.1 2010/05/03 21:44:04 bicatali Exp $
-
-EAPI=3
-inherit eutils
-
-DESCRIPTION="Extracts models of the Point Spread Function from FITS images"
-HOMEPAGE="http://www.astromatic.net/software/psfex"
-SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc plplot threads"
-
-RDEPEND="virtual/cblas
- sci-libs/lapack-atlas
- sci-libs/fftw:3.0
- plplot? ( sci-libs/plplot )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- # gentoo uses cblas instead of ptcblas (linked to threaded with eselect)
- sed -i \
- -e 's/ptcblas/cblas/g' \
- configure || die "sed failed"
-}
-
-src_configure() {
- econf \
- --with-atlas="${EPREFIX}/usr/$(get_libdir)/lapack/atlas" \
- $(use_with plplot) \
- $(use_enable threads)
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins doc/*.pdf || die "pdf doc install failed"
- fi
-}