aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-17 16:21:32 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-17 16:21:32 +0000
commit76ffb781ed7a917f23b67454e9f950e5e3b83527 (patch)
tree94fa8e1ddc7cb9ef80b78ea7896a5845f074f95b /sci-astronomy/skymaker/skymaker-3.1.0.ebuild
parentmove stuff to root (diff)
downloadsci-76ffb781ed7a917f23b67454e9f950e5e3b83527.tar.gz
sci-76ffb781ed7a917f23b67454e9f950e5e3b83527.tar.bz2
sci-76ffb781ed7a917f23b67454e9f950e5e3b83527.zip
moved overlay to new directory
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@979 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-astronomy/skymaker/skymaker-3.1.0.ebuild')
-rw-r--r--sci-astronomy/skymaker/skymaker-3.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-astronomy/skymaker/skymaker-3.1.0.ebuild b/sci-astronomy/skymaker/skymaker-3.1.0.ebuild
new file mode 100644
index 000000000..5054b7e51
--- /dev/null
+++ b/sci-astronomy/skymaker/skymaker-3.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Program that simulates astronomical images"
+HOMEPAGE="http://terapix.iap.fr/soft/skymaker"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads mpi"
+RESTRICT="test"
+
+DEPEND=">=sci-libs/fftw-3
+ mpi? ( virtual/mpi )"
+
+# mpi stuff untested.
+src_compile() {
+ use mpi || export MPICC="$(tc-getCC)"
+ local myconf
+ # --disable-threads is buggy
+ use threads && myconf="--enable-threads"
+ econf \
+ $(use_enable mpi) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
+}