aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-07-28 00:53:52 +0100
committerSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-07-28 00:53:52 +0100
commit8f47b452d05e99879ac2ccea776be3d9a82c5578 (patch)
tree0147fde2fd6c05456885df3f80c0ac553b50c459 /sci-astronomy/stuff/stuff-1.19.ebuild
parentskymaker: version bump (diff)
downloadsci-8f47b452d05e99879ac2ccea776be3d9a82c5578.tar.gz
sci-8f47b452d05e99879ac2ccea776be3d9a82c5578.tar.bz2
sci-8f47b452d05e99879ac2ccea776be3d9a82c5578.zip
suff initial import
Diffstat (limited to 'sci-astronomy/stuff/stuff-1.19.ebuild')
-rw-r--r--sci-astronomy/stuff/stuff-1.19.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-astronomy/stuff/stuff-1.19.ebuild b/sci-astronomy/stuff/stuff-1.19.ebuild
new file mode 100644
index 000000000..eebbbae71
--- /dev/null
+++ b/sci-astronomy/stuff/stuff-1.19.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Tool for automatic generation of astronomical catalogs"
+HOMEPAGE="http://astromatic.iap.fr/software/sktuff/"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/stuff/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
+}