aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-23 12:34:09 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-23 12:34:09 +0200
commit31948f21ddfb503f0c25d80ee1f38ba348fbc69d (patch)
tree3e4471e1cb6b889add274c3feb0060c3bc935892 /sci-astronomy/stuff
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-31948f21ddfb503f0c25d80ee1f38ba348fbc69d.tar.gz
sci-31948f21ddfb503f0c25d80ee1f38ba348fbc69d.tar.bz2
sci-31948f21ddfb503f0c25d80ee1f38ba348fbc69d.zip
Drop unnecessary die from emake
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-astronomy/stuff')
-rw-r--r--[l---------]sci-astronomy/stuff/stuff-1.26.0.ebuild36
1 files changed, 35 insertions, 1 deletions
diff --git a/sci-astronomy/stuff/stuff-1.26.0.ebuild b/sci-astronomy/stuff/stuff-1.26.0.ebuild
index 181cfccd3..1f57f85a8 120000..100644
--- a/sci-astronomy/stuff/stuff-1.26.0.ebuild
+++ b/sci-astronomy/stuff/stuff-1.26.0.ebuild
@@ -1 +1,35 @@
-stuff-9999.ebuild \ No newline at end of file
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit subversion
+ ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+#AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils
+
+DESCRIPTION="Tool for automatic generation of astronomical catalogs"
+HOMEPAGE="http://www.astromatic.net/software/stuff/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="threads"
+
+RDEPEND="sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=( $(use_enable threads) )
+ autotools-utils_src_configure
+}