aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2012-05-22 20:50:05 +0100
committerSébastien Fabbro <sebfabbro@gmail.com>2012-05-22 20:50:05 +0100
commit4d9518d5a93ed73b78aebbbc58a8ff679910f105 (patch)
treeba0badff5e265dbacfad8885bc3e1a3fa96ae0c8 /sci-astronomy/topcat
parentsci-astronomy/stilts: Initial import (diff)
downloadsci-4d9518d5a93ed73b78aebbbc58a8ff679910f105.tar.gz
sci-4d9518d5a93ed73b78aebbbc58a8ff679910f105.tar.bz2
sci-4d9518d5a93ed73b78aebbbc58a8ff679910f105.zip
sci-astronomy/topcat: Initial import
(Portage version: 2.1.10.60/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-astronomy/topcat')
-rw-r--r--sci-astronomy/topcat/ChangeLog10
-rw-r--r--sci-astronomy/topcat/Manifest2
-rw-r--r--sci-astronomy/topcat/metadata.xml14
-rw-r--r--sci-astronomy/topcat/topcat-3.9.ebuild35
4 files changed, 61 insertions, 0 deletions
diff --git a/sci-astronomy/topcat/ChangeLog b/sci-astronomy/topcat/ChangeLog
new file mode 100644
index 000000000..8d16b0753
--- /dev/null
+++ b/sci-astronomy/topcat/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-astronomy/topcat
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*topcat-3.9 (22 May 2012)
+
+ 22 May 2012; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +topcat-3.9.ebuild:
+ sci-astronomy/topcat: Initial import
+
diff --git a/sci-astronomy/topcat/Manifest b/sci-astronomy/topcat/Manifest
new file mode 100644
index 000000000..cb6330c09
--- /dev/null
+++ b/sci-astronomy/topcat/Manifest
@@ -0,0 +1,2 @@
+DIST topcat-3.9-full.jar 19982441 SHA256 df89a006a1dd36466570011ff0396eb1016f5b634bc16ea9abb23d7f94a7130c SHA512 88812d4b264c2e68d2713855291deb1607529401607c0d2e227999765d2ca9d4181183722d089d1ac2ea6884469ec29ebf4ef999930370ad159882d7870e9caa WHIRLPOOL 375d3a7b3959dafe96f2fac240743c293dbbd863f19dfbb6c9f9e59971565dfaf08de72003280782b379661e08fe6088b7e3d80d74bd5b200df767e0a7db133a
+DIST topcat-3.9-lite.jar 13246591 SHA256 2d87492a9dfd9bdcffe1e38541d88f6be901ac42642b8fc6e3682b5d0776ce10 SHA512 4c6f3f7fa9faa74bb9437f90d3f4553aaebe33613405926168d6b6d2b7501226bb60404cd0a3b3e0188b49e22a8262ac1fd9b6f6cb1d4cc55ca5073419e9f4cd WHIRLPOOL b1f7a6c12b267b1e8fd7593021957d674f71a432a22b7bb626f1c474b08a764b0af421b2b5ad9b6eb0bd0fb617489bf4010161377d1a362e492b7ecc4fae33f0
diff --git a/sci-astronomy/topcat/metadata.xml b/sci-astronomy/topcat/metadata.xml
new file mode 100644
index 000000000..cd12bff27
--- /dev/null
+++ b/sci-astronomy/topcat/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ Tool for OPerations on Catalogues And Tables is an interactive
+ graphical viewer and editor for tabular data. Its aim is to provide
+ most of the facilities that astronomers need for analysis and
+ manipulation of source catalogues and other tables, though it can be
+ used for non-astronomical data as well. It understands a number of
+ different astronomically important formats (including FITS and
+ VOTable) and more formats can be added.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-astronomy/topcat/topcat-3.9.ebuild b/sci-astronomy/topcat/topcat-3.9.ebuild
new file mode 100644
index 000000000..20d3ba585
--- /dev/null
+++ b/sci-astronomy/topcat/topcat-3.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit java-pkg-2
+
+DESCRIPTION="Interactive graphical viewer and editor for astronomical tables"
+HOMEPAGE="http://www.star.bris.ac.uk/~mbt/topcat/"
+SRC_COM="ftp://andromeda.star.bris.ac.uk/pub/star/${PN}/v${PV}"
+SRC_URI="${SRC_COM}/${PN}-lite.jar -> ${P}-lite.jar
+ !minimal? ( ${SRC_COM}/${PN}-full.jar -> ${P}-full.jar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+minimal"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ java-pkg_newjar "${DISTDIR}"/${P}-lite.jar ${PN}-lite.jar
+ java-pkg_dolauncher ${PN}-lite
+ if use minimal; then
+ dosym ${PN}-lite /usr/bin/${PN}
+ else
+ java-pkg_newjar "${DISTDIR}"/${P}-full.jar
+ java-pkg_dolauncher ${PN}-full
+ dosym ${PN}-full /usr/bin/${PN}
+ fi
+}