aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2012-05-18 00:19:48 +0100
committerSébastien Fabbro <sebfabbro@gmail.com>2012-05-18 00:19:48 +0100
commitd419e8bce2437211842deccfba7b54c389765046 (patch)
tree81b79de2ce2afddc29dd0c74060b06e526ca8860 /sci-astronomy/zebra
parentsci-libs/optpp: Initial import (diff)
downloadsci-d419e8bce2437211842deccfba7b54c389765046.tar.gz
sci-d419e8bce2437211842deccfba7b54c389765046.tar.bz2
sci-d419e8bce2437211842deccfba7b54c389765046.zip
sci-astronomy/zebra: Initial import
(Portage version: 2.1.10.60/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-astronomy/zebra')
-rw-r--r--sci-astronomy/zebra/ChangeLog10
-rw-r--r--sci-astronomy/zebra/Manifest1
-rw-r--r--sci-astronomy/zebra/metadata.xml22
-rw-r--r--sci-astronomy/zebra/zebra-1.01.ebuild43
4 files changed, 76 insertions, 0 deletions
diff --git a/sci-astronomy/zebra/ChangeLog b/sci-astronomy/zebra/ChangeLog
new file mode 100644
index 000000000..72dc7db77
--- /dev/null
+++ b/sci-astronomy/zebra/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-astronomy/zebra
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*zebra-1.01 (17 May 2012)
+
+ 17 May 2012; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +zebra-1.01.ebuild:
+ sci-astronomy/zebra: Initial import
+
diff --git a/sci-astronomy/zebra/Manifest b/sci-astronomy/zebra/Manifest
new file mode 100644
index 000000000..20fe199f6
--- /dev/null
+++ b/sci-astronomy/zebra/Manifest
@@ -0,0 +1 @@
+DIST zebra-1.01.tar.gz 1574479 SHA256 931a177376ad8275a00901fdbfc7501282ad8553bf82c8d9bae90813e3bd089f SHA512 68372227d095b84301099f5fbc541778642de6dcbdb2d76f33215263752ef452145fb061132a940c14fb488617f7b95ddc6aea298063cba44e0c17bd4d626f80 WHIRLPOOL 652affbef09eac6b290f090c71ac3022cfea6370ff25f01b7ad28a8d0605655e9f157761b280199e79da19a708469e6f620224142eddc2c38199e836fd250bde
diff --git a/sci-astronomy/zebra/metadata.xml b/sci-astronomy/zebra/metadata.xml
new file mode 100644
index 000000000..b8ef7bb1f
--- /dev/null
+++ b/sci-astronomy/zebra/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ The Zurich Extragalactic Bayesian Redshift Analyzer is a software to
+ compute and analyze photometric redshifts of galaxies.
+ ZEBRA combines and extends several of the classical approaches to
+ produce accurate photometric redshifts down to faint magnitudes. In
+ particular, ZEBRA uses the template-fitting approach to produce
+ Maximum Likelihood and Bayesian redshift estimates based on:
+ * An automatic iterative technique to correct the original set of
+ galaxy templates to best represent the SEDs of real galaxies at
+ different redshifts;
+ * A training set of spectroscopic redshifts for a small fraction of
+ the photometric sample, to improve the robustness of the
+ photometric redshift estimates; and
+ * An iterative technique for Bayesian redshift estimates, which
+ extracts the full two-dimensional redshift and template likelihood
+ function for each galaxy.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-astronomy/zebra/zebra-1.01.ebuild b/sci-astronomy/zebra/zebra-1.01.ebuild
new file mode 100644
index 000000000..7463821b1
--- /dev/null
+++ b/sci-astronomy/zebra/zebra-1.01.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Galaxy redhift Bayesian analyzer"
+HOMEPAGE="http://www.astro.phys.ethz.ch/exgal_ocosm/zebra/index.html"
+SRC_URI="http://www.astro.phys.ethz.ch/exgal_ocosm/zebra/tar/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="sci-libs/gsl
+ sci-libs/lapackpp
+ virtual/blas
+ virtual/cblas
+ virtual/lapack"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ myeconfargs+=(
+ --with-blas="$(pkg-config --libs blas)"
+ --with-cblas="$(pkg-config --libs cblas)"
+ --with-lapack="$(pkg-config --libs lapack)"
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc doc/*.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r scripts examples
+ fi
+}