aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <sfabbro@uvic.ca>2012-07-26 16:27:06 -0700
committerSebastien Fabbro <sfabbro@uvic.ca>2012-07-26 16:27:06 -0700
commit16a226ca027f86c043fc3871bf12736db89f7a68 (patch)
tree169ecb8a69199ee700eb62e03e18e5bb09ca8bcf /sci-astronomy/zpeg
parentdev-cpp/eigen: Version bump. Changed license to MPL-2 (diff)
downloadsci-16a226ca027f86c043fc3871bf12736db89f7a68.tar.gz
sci-16a226ca027f86c043fc3871bf12736db89f7a68.tar.bz2
sci-16a226ca027f86c043fc3871bf12736db89f7a68.zip
sci-astronomy/zpeg: Initial import
(Portage version: 2.2.01.20796-prefix/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-astronomy/zpeg')
-rw-r--r--sci-astronomy/zpeg/ChangeLog9
-rw-r--r--sci-astronomy/zpeg/Manifest1
-rw-r--r--sci-astronomy/zpeg/metadata.xml14
-rw-r--r--sci-astronomy/zpeg/zpeg-5.23.ebuild63
4 files changed, 87 insertions, 0 deletions
diff --git a/sci-astronomy/zpeg/ChangeLog b/sci-astronomy/zpeg/ChangeLog
new file mode 100644
index 000000000..72e4b6d54
--- /dev/null
+++ b/sci-astronomy/zpeg/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-astronomy/zpeg
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*zpeg-5.23 (26 Jul 2012)
+
+ 26 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +zpeg-5.23.ebuild:
+ sci-astronomy/zpeg: Initial import
diff --git a/sci-astronomy/zpeg/Manifest b/sci-astronomy/zpeg/Manifest
new file mode 100644
index 000000000..25296ee59
--- /dev/null
+++ b/sci-astronomy/zpeg/Manifest
@@ -0,0 +1 @@
+DIST zpeg_5.23.tar.gz 37541120 SHA256 de2b6dd120a4bf89e3b49c924923334b8d25e9209539a7de5264f501698b4fc2 SHA512 4bc05bb504531317de7dbb76b9f949ee346b401d3ab90e5a4a08d1b268f98aa1f2ca2895003a48a136e0f9316e976daa5ee2198e31353eaf7462ad40a302cadc WHIRLPOOL eb228ae069ddc3fa71da8e0858ff09cf6518ba5e506e54c68b097402ac053b6e4242b0781720287c37b8ea6b43b457dc015115617044b19ca3e2cf71da2f980c
diff --git a/sci-astronomy/zpeg/metadata.xml b/sci-astronomy/zpeg/metadata.xml
new file mode 100644
index 000000000..46307f890
--- /dev/null
+++ b/sci-astronomy/zpeg/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ Z-PEG is a software anybody can use to compute photometric
+ redshifts. In short, Z-PEG performs a chi square minimization of the
+ distance between observed photometric bands and synthetic photometry
+ from galaxies simulated by the evolutionary code PEGASE.
+</longdescription>
+<use>
+<flag name='gdl'>Install GDL/IDL plotting routines</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-astronomy/zpeg/zpeg-5.23.ebuild b/sci-astronomy/zpeg/zpeg-5.23.ebuild
new file mode 100644
index 000000000..51792f95b
--- /dev/null
+++ b/sci-astronomy/zpeg/zpeg-5.23.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit fortran-2
+
+MYP=${PN}_${PV}
+
+DESCRIPTION="Galaxy photometric redshifts from evolutionary synthesis"
+HOMEPAGE="http://imacdlb.iap.fr:8080/cgi-bin/zpeg/zpeg.pl"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/leborgne/${PN}/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="gdl"
+
+RDEPEND="gdl? ( dev-lang/gdl )"
+DEPEND="virtual/fortran"
+
+S="${WORKDIR}/${MYP}"
+
+FORTRAN_STANDARD="90"
+
+src_prepare() {
+ # save configure for tests
+ cp configure{,.orig}
+ # install data in FHS
+ sed -i \
+ -e "s:ZPEG_ROOT=.*:ZPEG_ROOT=${EPREFIX}/usr/share/${PN}:" \
+ configure || die
+}
+
+src_compile() {
+ # not worth debugging parallell build failures which is due to
+ # fortran modules missing dependencies)
+ emake -j1 -C src
+}
+
+src_test() {
+ # test only works with hardcoded path, so reconfigure and recompile
+ mv bin/zpeg{,.orig}
+ mv configure{.orig,}
+ emake -C src clean && econf && emake -j1 -C src
+ cd test
+ ../bin/zpeg -V ZPEG1_cata.cat -o hdf.zpeg -p hdf.par -t hdf.par.tmp || die
+ mv bin/zpeg{.orig,}
+}
+
+src_install() {
+ dobin bin/zpeg
+ insinto /usr/share/${PN}
+ doins -r data VERSION
+ dodoc HISTORY
+ echo > 99zpeg "ZPEG_ROOT=${EROOT}/usr/share/${PN}"
+ doenvd 99zpeg
+ if use gdl; then
+ insinto /usr/share/gnudatalanguage/${PN}
+ doins idl/*.pro
+ fi
+}