aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-02-28 20:24:15 +0000
committerJustin Lecher <jlec@gentoo.org>2017-02-28 20:55:03 +0000
commit71931dceb33deeddf7f3699519c4e893f54931f6 (patch)
tree11b6722af4b70e08516c256c846c7c3eddc162e9 /sci-astronomy/zpeg
parentdev-lang/berkeley_upc_translator: QA fixes (diff)
downloadsci-71931dceb33deeddf7f3699519c4e893f54931f6.tar.gz
sci-71931dceb33deeddf7f3699519c4e893f54931f6.tar.bz2
sci-71931dceb33deeddf7f3699519c4e893f54931f6.zip
sci-astronomy/zpeg: QA fixes
Bump to EAPI=6 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-astronomy/zpeg')
-rw-r--r--sci-astronomy/zpeg/zpeg-5.23.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sci-astronomy/zpeg/zpeg-5.23.ebuild b/sci-astronomy/zpeg/zpeg-5.23.ebuild
index c4f0b6480..d8daa308d 100644
--- a/sci-astronomy/zpeg/zpeg-5.23.ebuild
+++ b/sci-astronomy/zpeg/zpeg-5.23.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit fortran-2
@@ -50,11 +50,15 @@ src_test() {
src_install() {
dobin bin/zpeg
+
insinto /usr/share/${PN}
doins -r data VERSION
+
dodoc HISTORY
- echo > 99zpeg "ZPEG_ROOT=${EROOT}/usr/share/${PN}"
- doenvd 99zpeg
+
+ echo > "${T}"/99zpeg "ZPEG_ROOT=${EROOT}/usr/share/${PN}"
+ doenvd "${T}"/99zpeg
+
if use gdl; then
insinto /usr/share/gnudatalanguage/${PN}
doins idl/*.pro