aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-01-12 15:21:48 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-01-12 15:21:48 +0000
commit2881cdf6c3b35d80658ea9f6735c17ccebb4501d (patch)
tree02d32394554b2ba4b27126c25e3dbe28e39de6cc /sci-astronomy
parentadded celestia-1.4.0.ebuild (diff)
downloadsci-2881cdf6c3b35d80658ea9f6735c17ccebb4501d.tar.gz
sci-2881cdf6c3b35d80658ea9f6735c17ccebb4501d.tar.bz2
sci-2881cdf6c3b35d80658ea9f6735c17ccebb4501d.zip
ds9-4.0_beta7.ebuild: added () for dohtml
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@46 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ds9/Manifest4
-rw-r--r--sci-astronomy/ds9/ds9-4.0_beta7.ebuild13
2 files changed, 9 insertions, 8 deletions
diff --git a/sci-astronomy/ds9/Manifest b/sci-astronomy/ds9/Manifest
index 468c51515..7463b32be 100644
--- a/sci-astronomy/ds9/Manifest
+++ b/sci-astronomy/ds9/Manifest
@@ -1,5 +1,5 @@
-MD5 6c7b03bbb9d402e7ad92d8a1b71e0601 ds9-4.0_beta7.ebuild 1589
-MD5 1a9e880154be5521b9aacc906b1f407a metadata.xml 370
MD5 4785ef89cd9307e1c7c6489336e9026a ChangeLog 271
+MD5 83eb83806e6220d0424387ce66c8c550 ds9-4.0_beta7.ebuild 1489
MD5 a8d8c98fa3633546413bd278f3af9ca8 files/digest-ds9-4.0_beta7 63
MD5 1368902cfd7fbe8a1c52bf34c2829765 files/ds9-Makefile.patch 2040
+MD5 1a9e880154be5521b9aacc906b1f407a metadata.xml 370
diff --git a/sci-astronomy/ds9/ds9-4.0_beta7.ebuild b/sci-astronomy/ds9/ds9-4.0_beta7.ebuild
index 9521bbda1..ce2fb29c1 100644
--- a/sci-astronomy/ds9/ds9-4.0_beta7.ebuild
+++ b/sci-astronomy/ds9/ds9-4.0_beta7.ebuild
@@ -26,7 +26,7 @@ S=${WORKDIR}/sao${PN}
src_unpack() {
unpack ${A}
cd ${S}
- # The patch is to speed up the compilation
+ # The patch is to speed up the compilation
# (avoid generating tcl man files for ex.)
# and avoid local install bugs with symbolic linking.
epatch ${FILESDIR}/${PN}-Makefile.patch
@@ -38,15 +38,16 @@ src_compile() {
use x86 && ln -s make.linux make.include
use amd64 && ln -s make.linux64 make.include
emake -j1 || die "emake failed"
+ # only install locally
make install || die "make install (local) failed"
}
src_install () {
- dobin bin/ds9 || die "dobin ds9 failed"
+ dobin bin/ds9
if use xpa; then
- dobin bin/xpa* || die "dobin xpa failed"
- doman man/man?/xpa* || die "doman xpa failed"
+ dobin bin/xpa*
+ doman man/man?/xpa*
fi
- dodoc README acknowledgement copyright || die "dodoc failed"
- use doc && dohtml ds9/doc/* || die "dohtml failed"
+ dodoc README acknowledgement copyright
+ use doc && dohtml ds9/doc/*
}