aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-07-23 18:29:12 +0100
committerSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-07-23 18:29:12 +0100
commit51e48fefc3d427f83c8110583e122b1a376c3d65 (patch)
tree506d366267454087a923dadde3cb908658bb5423 /sci-astronomy
parentadded prroper license (diff)
downloadsci-51e48fefc3d427f83c8110583e122b1a376c3d65.tar.gz
sci-51e48fefc3d427f83c8110583e122b1a376c3d65.tar.bz2
sci-51e48fefc3d427f83c8110583e122b1a376c3d65.zip
gasgano version bump
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/gasgano/gasgano-2.3.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-astronomy/gasgano/gasgano-2.3.0.ebuild b/sci-astronomy/gasgano/gasgano-2.3.0.ebuild
new file mode 100644
index 000000000..1166cf34d
--- /dev/null
+++ b/sci-astronomy/gasgano/gasgano-2.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit java-pkg-2
+
+PDOC=VLT-PRO-ESO-19000-1932-V4
+
+DESCRIPTION="ESO astronomical data file organizer"
+HOMEPAGE="http://www.eso.org/sci/data-processing/software/gasgano/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/${PN}/${P}.tar.gz
+ doc? ( ${HOMEPAGE}/${PDOC}.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6
+ dev-java/gnu-regexp
+ dev-java/junit
+ dev-java/jal"
+
+src_prepare() {
+ sed -i \
+ -e 's:BASE.*=.*:BASE=/usr/share/gasgano:' \
+ bin/gasgano || die
+}
+
+src_install() {
+ dobin bin/* || die
+ java-pkg_dojar share/*.jar
+ insinto /usr/share/${PN}/config
+ doins -r config/*.rul || die
+ make_desktop_entry gasgano "Gasgano FITS Organizer"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ newins "${DISTDIR}"/${PDOC}.pdf user-manual.pdf
+ fi
+}