aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <sfabbro@uvic.ca>2012-07-04 14:14:48 -0700
committerSebastien Fabbro <sfabbro@uvic.ca>2012-07-04 14:14:48 -0700
commita68ef808d8313cc867af31052cf10883ef328d29 (patch)
tree5b797687a6f2cbe95296ac77bf3af4abd5097acd /sci-astronomy
parentdev-util/nvidia-cuda-sdk: Adapted to newer nvidia-cuda-sdk (diff)
downloadsci-a68ef808d8313cc867af31052cf10883ef328d29.tar.gz
sci-a68ef808d8313cc867af31052cf10883ef328d29.tar.bz2
sci-a68ef808d8313cc867af31052cf10883ef328d29.zip
sci-astronomy/sextractor: Live version, introduced prefix love
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/sextractor/ChangeLog8
-rw-r--r--sci-astronomy/sextractor/Manifest2
-rw-r--r--sci-astronomy/sextractor/metadata.xml6
-rw-r--r--sci-astronomy/sextractor/sextractor-2.8.6-r1.ebuild14
-rw-r--r--sci-astronomy/sextractor/sextractor-9999.ebuild67
5 files changed, 89 insertions, 8 deletions
diff --git a/sci-astronomy/sextractor/ChangeLog b/sci-astronomy/sextractor/ChangeLog
index 67fe448f2..fc4b8f942 100644
--- a/sci-astronomy/sextractor/ChangeLog
+++ b/sci-astronomy/sextractor/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sci-astronomy/sextractor
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/sextractor/ChangeLog,v 1.3 2011/08/04 18:32:38 bicatali Exp $
+*sextractor-9999 (04 Jul 2012)
+
+ 04 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ sextractor-2.8.6-r1.ebuild, +sextractor-9999.ebuild, metadata.xml:
+ Live version, introduced prefix love
+
*sextractor-2.8.6-r1 (28 Nov 2011)
28 Nov 2011; Sébastien Fabbro <bicatali@gentoo.org>
diff --git a/sci-astronomy/sextractor/Manifest b/sci-astronomy/sextractor/Manifest
index 90ce65ca3..7581016e5 100644
--- a/sci-astronomy/sextractor/Manifest
+++ b/sci-astronomy/sextractor/Manifest
@@ -1 +1 @@
-DIST sextractor-2.8.6.tar.gz 3994622 RMD160 98319c54ab3af0d4a91c3ffa70e7d5148b06d67a SHA1 103ac2d51d9bae9fcbc5dda3031d82cd127f8250 SHA256 dde34594c2a1324f0951272e404e55d0d4cb0607f8ea18a61f2563bb67f494ac
+DIST sextractor-2.8.6.tar.gz 3994622 RMD160 98319c54ab3af0d4a91c3ffa70e7d5148b06d67a SHA1 103ac2d51d9bae9fcbc5dda3031d82cd127f8250 SHA256 dde34594c2a1324f0951272e404e55d0d4cb0607f8ea18a61f2563bb67f494ac SHA512 c8847f4feb45000eac02ae8fe9747b6c4a1faf0d8722e87f07699c25d71a1bcd44d8cf88df852453a3a45762deb7420cb79aca1d763543f1253755a59f585b70 WHIRLPOOL 4a8be697df11cac64980e8ee828ea61ba839a67219a9918e941a1354fc3294c80d4442eb7f91202d16315d7f454d73897a156921acd090cff836838f8eba2c29
diff --git a/sci-astronomy/sextractor/metadata.xml b/sci-astronomy/sextractor/metadata.xml
index 8b8931e59..49bc757b8 100644
--- a/sci-astronomy/sextractor/metadata.xml
+++ b/sci-astronomy/sextractor/metadata.xml
@@ -10,4 +10,10 @@
ability to automatically separate stars and galaxy using neural
networks.
</longdescription>
+<use>
+<flag name='modelfit'>
+ Enable profile model fitting, needs <pkg>sci-libs/atlas</pkg>
+ and <pkg>sci-libs/fftw</pkg>
+</flag>
+</use>
</pkgmetadata>
diff --git a/sci-astronomy/sextractor/sextractor-2.8.6-r1.ebuild b/sci-astronomy/sextractor/sextractor-2.8.6-r1.ebuild
index 1db0e066f..53aead87b 100644
--- a/sci-astronomy/sextractor/sextractor-2.8.6-r1.ebuild
+++ b/sci-astronomy/sextractor/sextractor-2.8.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -11,7 +11,7 @@ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
LICENSE="CeCILL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc threads"
RDEPEND="virtual/cblas
@@ -23,8 +23,10 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-configure.patch
local mycblas=atlcblas myclapack=atlclapack
if use threads; then
- [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && mycblas=ptcblas
- [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] && myclapack=ptclapack
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptcblas.so ]] && \
+ mycblas=ptcblas
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptclapack.so ]] && \
+ myclapack=ptclapack
fi
sed -i \
-e "s/-lcblas/-l${mycblas}/g" \
@@ -50,6 +52,6 @@ src_install () {
}
pkg_postinst() {
- elog "SExtractor examples configuration files are located"
- elog "in ${EROOT}/${CONFDIR} and are not loaded anymore by default."
+ elog "SExtractor examples configuration files are located in"
+ elog "${EROOT}/${CONFDIR} and are not loaded anymore by default."
}
diff --git a/sci-astronomy/sextractor/sextractor-9999.ebuild b/sci-astronomy/sextractor/sextractor-9999.ebuild
new file mode 100644
index 000000000..518564013
--- /dev/null
+++ b/sci-astronomy/sextractor/sextractor-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+if [[ ${PV} == "9999" ]] ; then
+ _SVN=subversion
+ ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit ${_SVN} autotools
+
+DESCRIPTION="Extract catalogs of sources from astronomical FITS images"
+HOMEPAGE="http://www.astromatic.net/software/sextractor"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc modelfit threads"
+
+RDEPEND="modelfit? ( virtual/cblas sci-libs/atlas[lapack] sci-libs/fftw:3.0 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ if use modelfit; then
+ local mycblas=atlcblas myclapack=atlclapack
+ if use threads; then
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptcblas.so ]] && \
+ mycblas=ptcblas
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptclapack.so ]] && \
+ myclapack=ptclapack
+ fi
+ sed -i \
+ -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s/-llapack/-l${myclapack}/g" \
+ -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
+ acx_atlas.m4 || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --with-atlas-incdir="${EPREFIX}/usr/include/atlas" \
+ $(use_enable modelfit model-fitting) \
+ $(use_enable threads)
+}
+
+src_install () {
+ default
+ CONFDIR=/usr/share/sextractor
+ insinto ${CONFDIR}
+ doins config/*
+ use doc && dodoc doc/*
+}
+
+pkg_postinst() {
+ elog "SExtractor examples configuration files are located in"
+ elog "${EROOT}/${CONFDIR} and are not loaded anymore by default."
+}