aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-13 04:10:28 -0500
committerHorea Christian <chr@chymera.eu>2023-01-13 04:10:28 -0500
commit8411b6dbba5a94a2e74255cf96c3bfa208f4b81a (patch)
tree6ab283608009f54774e1aa3288b41e09c56bb967 /sci-biology/bx-python/bx-python-0.9.0.ebuild
parentsci-biology/bx-python: updated PYTHON_COMPAT (diff)
downloadsci-8411b6dbba5a94a2e74255cf96c3bfa208f4b81a.tar.gz
sci-8411b6dbba5a94a2e74255cf96c3bfa208f4b81a.tar.bz2
sci-8411b6dbba5a94a2e74255cf96c3bfa208f4b81a.zip
sci-biology/bx-python: add 0.9.0
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-biology/bx-python/bx-python-0.9.0.ebuild')
-rw-r--r--sci-biology/bx-python/bx-python-0.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-biology/bx-python/bx-python-0.9.0.ebuild b/sci-biology/bx-python/bx-python-0.9.0.ebuild
new file mode 100644
index 000000000..86ef4f79a
--- /dev/null
+++ b/sci-biology/bx-python/bx-python-0.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for rapid implementation of genome scale analyses"
+HOMEPAGE="https://github.com/bxlab/bx-python"
+SRC_URI="https://github.com/bxlab/bx-python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+# has file collision with sci-biology/RSeQC
+
+# ToDo: fix doc building:
+# Reason: TemplateNotFound('i')
+#distutils_enable_sphinx doc/source