aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-07-29 22:47:12 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-07-29 22:47:12 +0200
commit3bdd3d1c35c9e23cbc13e86dcb8c4b2321fd2620 (patch)
tree267570c9262cbd93b68fb41bd2e3019ecfe4a332 /sci-biology/ensembl-tools/ensembl-tools-85.ebuild
parentdev-perl/Bio-DB-HTS: new package, needs more fixes (diff)
downloadsci-3bdd3d1c35c9e23cbc13e86dcb8c4b2321fd2620.tar.gz
sci-3bdd3d1c35c9e23cbc13e86dcb8c4b2321fd2620.tar.bz2
sci-3bdd3d1c35c9e23cbc13e86dcb8c4b2321fd2620.zip
sci-biology/ensembl-tools: new package, needs more fixes, upstream contacted
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-biology/ensembl-tools/ensembl-tools-85.ebuild')
-rw-r--r--sci-biology/ensembl-tools/ensembl-tools-85.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-biology/ensembl-tools/ensembl-tools-85.ebuild b/sci-biology/ensembl-tools/ensembl-tools-85.ebuild
new file mode 100644
index 000000000..642caf8eb
--- /dev/null
+++ b/sci-biology/ensembl-tools/ensembl-tools-85.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit perl-module
+
+DESCRIPTION="Bioinformatics tools incl. Variant Effect Predictor (VEP)"
+HOMEPAGE="http://grch37.ensembl.org/info/docs/tools/vep/script/index.html"
+SRC_URI="https://github.com/Ensembl/ensembl-tools/archive/release/${PV}.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="" # BUG: needs Bio::EnsEMBL::Registry
+IUSE=""
+
+DEPEND=""
+#DEPEND="dev-perl/Perl-XS
+# dev-perl/Bio-DB-HTS"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/ensembl-tools-release-${PV}"
+
+src_install(){
+ perl_set_version
+ insinto ${VENDOR_LIB}/${PN}
+ cd scripts/variant_effect_predictor || die
+ perl INSTALL.pl --DESTDIR="${EPREFIX}"/"${DESTDIR}" --AUTO ac
+ newdoc README.txt variant_effect_predictor.txt
+ cd ../../scripts/region_reporter || die
+ dobin *.pl
+ newdoc README.txt region_reporter.txt
+ cd ../../scripts/assembly_converter
+ dobin *.pl
+ insinto ${VENDOR_LIB}/${PN}
+ doins *.pm
+ newdoc README.txt assembly_converter.txt
+ insinto /usr/share/"${PN}"/examples
+ doins assemblymapper.in
+ cd ../../scripts/id_history_converter
+ dobin *.pl
+ newdoc README.txt id_history_converter.txt
+ insinto /usr/share/"${PN}"/examples
+ doins idmapper.in
+}