aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-12-02 22:38:56 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-12-02 22:38:56 +0100
commit89901ef8af86f09919417a38d7d2d79e349f6caf (patch)
tree0af21113b3060dc6a2b6f32d0735852678e06e53 /sci-biology/ensembl-tools/ensembl-tools-86.ebuild
parentsci-biology/stacks: add missing dependency (diff)
downloadsci-89901ef8af86f09919417a38d7d2d79e349f6caf.tar.gz
sci-89901ef8af86f09919417a38d7d2d79e349f6caf.tar.bz2
sci-89901ef8af86f09919417a38d7d2d79e349f6caf.zip
sci-biology/ensembl-tools: note dependency not yet in science overlay
Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-biology/ensembl-tools/ensembl-tools-86.ebuild')
-rw-r--r--sci-biology/ensembl-tools/ensembl-tools-86.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-biology/ensembl-tools/ensembl-tools-86.ebuild b/sci-biology/ensembl-tools/ensembl-tools-86.ebuild
new file mode 100644
index 000000000..cee11494b
--- /dev/null
+++ b/sci-biology/ensembl-tools/ensembl-tools-86.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit perl-module
+
+DESCRIPTION="Bioinformatics tools incl. Variant Effect Predictor (VEP)"
+HOMEPAGE="http://www.ensembl.org/info/docs/tools/vep/script
+ http://www.ensembl.org/info/docs/tools/vep/script/vep_plugins.html"
+SRC_URI="https://github.com/Ensembl/ensembl-tools/archive/release/${PV}.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="" # BUG: needs Bio::EnsEMBL::Registry
+IUSE=""
+
+DEPEND="dev-perl/File-Copy-Recursive
+ dev-perl/Archive-Extract
+ dev-perl/Bio-DB-HTS"
+# BUG: needs Bio::EnsEMBL::Registry from http://www.ensembl.org/info/docs/api/api_installation.html
+# dev-perl/Bio-EnsEMBL" #
+#DEPEND="dev-perl/Perl-XS
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/ensembl-tools-release-${PV}"
+
+src_install(){
+ perl_set_version
+ insinto ${VENDOR_LIB}/${PN}
+ cd scripts/variant_effect_predictor || die
+ # FIXME: INSTALL.pl does not exit upon error
+ ./INSTALL.pl --DESTDIR="${DESTDIR}"/"${EPREFIX}" --AUTO=ac || die
+ newdoc README.txt variant_effect_predictor.txt
+ cd ../../scripts/region_reporter || die
+ dobin *.pl
+ newdoc README.txt region_reporter.txt
+ cd ../../scripts/assembly_converter
+ dobin *.pl
+ insinto /usr/share/"${PN}"/examples
+ doins assemblymapper.in
+ #insinto ${VENDOR_LIB}/${PN}
+ #doins *.pm
+ newdoc README.txt assembly_converter.txt
+ insinto /usr/share/"${PN}"/examples
+ doins assemblymapper.in
+ cd ../../scripts/id_history_converter
+ dobin *.pl
+ newdoc README.txt id_history_converter.txt
+ insinto /usr/share/"${PN}"/examples
+ doins idmapper.in
+}