aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2011-05-11 10:58:07 +0200
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2011-05-11 10:58:07 +0200
commit46b6d2ba846a0e8ea47e0de6da3946d673aa7c79 (patch)
treed6492f2b3e1bbd81bb69b1dda44e96fabd7211c8 /sci-biology/gbrowse/gbrowse-2.26.ebuild
parentsci-mathematics/gambit: deleted from old category sci-misc (diff)
downloadsci-46b6d2ba846a0e8ea47e0de6da3946d673aa7c79.tar.gz
sci-46b6d2ba846a0e8ea47e0de6da3946d673aa7c79.tar.bz2
sci-46b6d2ba846a0e8ea47e0de6da3946d673aa7c79.zip
sci-biology/gbrowse-2.26: fixed sanbox violation but webap-config bug pops up afterwards (happens later during install)
(Portage version: 2.1.9.43/git/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'sci-biology/gbrowse/gbrowse-2.26.ebuild')
-rw-r--r--sci-biology/gbrowse/gbrowse-2.26.ebuild30
1 files changed, 25 insertions, 5 deletions
diff --git a/sci-biology/gbrowse/gbrowse-2.26.ebuild b/sci-biology/gbrowse/gbrowse-2.26.ebuild
index b525bcca3..89000cfd4 100644
--- a/sci-biology/gbrowse/gbrowse-2.26.ebuild
+++ b/sci-biology/gbrowse/gbrowse-2.26.ebuild
@@ -50,7 +50,6 @@ DEPEND=">=dev-lang/perl-5.8.8
# * Bio::DB::Sam is not installed
# * DBD::Pg is not installed
-
RDEPEND="${DEPEND}
>=www-servers/apache-2.0.47
www-apache/mod_fastcgi
@@ -81,12 +80,17 @@ RDEPEND="${DEPEND}
src_prepare() {
sed -i 's/return unless -t STDIN/return/' install_util/GBrowseInstall.pm || die
sed -i 's/process_/bp_process_/g' INSTALL || die
- epatch "${FILESDIR}"/GBrowseInstall.pm.patch || die "Failed to patch"
+ epatch "${FILESDIR}"/GBrowseInstall.pm-"${PV}".patch || die "Failed to patch"
+ epatch "${FILESDIR}"/GBrowseInstall.pm-disable-gbrowse_metadb_config.pl"${PV}".pm.patch || die "Failed to patch"
}
src_configure() {
# GBROWSE_ROOT is the root path in SRC_URI to be prepended
# /usr/share/webapps/gbrowse/2.03/htdocs/etc/gbrowse/GBrowse.conf
+
+ # if we use CONF="${D}${MY_HTDOCSDIR}"/etc/gbrowse the the install process
+ # will not find currently installed config files and therefore place *.conf
+ # files into "{$S}"/blib/conf/*.conf instead of creating "{$S}"/blib/conf/*.conf.new
webapp_src_preinst
perl Makefile.PL \
HTDOCS="${MY_HTDOCSDIR}" \
@@ -104,6 +108,12 @@ src_configure() {
DO_XS=1 \
NONROOT=1 \
|| die
+
+ #sed -i 's#DBI:SQLite:#DBI:SQLite:'${D}'#' "${S}"/install_util/GBrowseInstall.pm || die
+ #sed -i 's#DBI:SQLite:#DBI:SQLite:'${D}'#' "${S}"/conf/GBrowse.conf || die
+ #sed -i 's#/var/www/gbrowse2/databases/#'${D}'/var/www/gbrowse2/databases/#' "${S}"/_build/build_params
+ #sed -i 's#/var/www/gbrowse2/databases/#'${D}'/var/www/gbrowse2/databases/#' "${S}"/_build/config_data
+ #sed -i 's#/var/www/gbrowse2/databases/#'${D}'/var/www/gbrowse2/databases/#' "${S}"/_build/runtime_params
}
src_install() {
@@ -111,25 +121,35 @@ src_install() {
perl-module_src_install
# TODO: write our own readme
- webapp_postinst_txt en "${S}"/INSTALL
- webapp_src_install || die "Failed running webapp_src_install"
+ webapp_src_preinst
+ webapp_postinst_txt en "${S}"/INSTALL || die
+ webapp_src_install
# should create a /etc/init.d/ startup script based on this
# /var/tmp/portage/sci-biology/gbrowse-2.03/work/GBrowse-2.03/etc/init.d/gbrowse-slave
+ # pre-create the directory so we can force its owner later on
+ mkdir -p "${D}"/var/www/gbrowse2/databases || die
chown -R apache.apache "${D}"/var/www/gbrowse2/databases || die
-
mkdir -p "${D}"/var/www/localhost/htdocs/gbrowse || die
+
ln -s "${D}"/var/tmp/gbrowse2/images "${D}"/var/www/localhost/htdocs/gbrowse/i || die
einfo "Probably you want to install a cron job to remove the generated temporary images:"
einfo "find /var/tmp/gbrowse2/images -type f -atime +20 -print -exec rm {}"
einfo "Make sure you compiled apache with +cgi and copy ${FILESDIR}/gbrowse.conf.vhosts.d to /etc/apache2/vhosts.d/"
+
+ sed -i "s#"${D}"##g" "${S}"/install_util/GBrowseInstall.pm || die
+ sed -i "s#"${D}"##" "${S}"/blib/conf/GBrowse.conf*
+ sed -i 's#DBI:SQLite:'${D}'/var/www/gbrowse2/databases/#DBI:SQLite:/var/www/gbrowse2/databases/#' "${S}"/install_util/GBrowseInstall.pm || die
}
pkg_postinst() {
webapp_pkg_postinst || die "webapp_pkg_postinst failed"
+
+ einfo "Please run gbrowse_metadb_config.pl to upate SQlite flatfiles or the live database"
+ einfo "This was disabled by "${FILESDIR}"/GBrowseInstall.pm-disable-gbrowse_metadb_config.pl.pm.patch"
}
src_test() {