aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-03-30 07:42:42 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-03-30 07:42:42 +0100
commita6b601e64f7b9313fc7d7c2fec43d0f4d4d7ec1f (patch)
treec025ec904848ec45a281c69a069c5adfc91876f2 /sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
parentsci-biology/ncbi-tools++: version bump (diff)
downloadsci-a6b601e64f7b9313fc7d7c2fec43d0f4d4d7ec1f.tar.gz
sci-a6b601e64f7b9313fc7d7c2fec43d0f4d4d7ec1f.tar.bz2
sci-a6b601e64f7b9313fc7d7c2fec43d0f4d4d7ec1f.zip
sci-biology/ncbi-tools++: document possible issue with builds
I have the following defined due to ncbi-tools++-18.0.0 installed on my system: /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/32: /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0: /usr/lib/gcc/x86_64-pc-linux-gnu/7.3.0/32: /usr/lib/gcc/x86_64-pc-linux-gnu/7.3.0: /usr/lib/llvm/7/lib32: /usr/lib/llvm/7/lib64: /usr/lib64/itcl4.1.1: /usr/lib64/itk4.1.0: /lib64: /usr/lib64: /usr/local/lib64: /lib32: /usr/lib32: /usr/lib64/rust-1.29.2: /usr/lib64/R/lib: /usr/lib64/fltk: /usr/lib64/ncbi-tools++: /usr/lib64/staden: grep: /etc: No such file or directory grep: /etc/env.d: No such file or directory /etc/env.d/99ncbi-tools++:LDPATH=/usr/lib64/ncbi-tools++ ... That in turn makes linker pick "${WORKDIR}"/ncbi_cxx--22_0_0_build/lib/* files but later overrides some of them with /usr/lib64/ncbi-tools++/*, depending on the ordering of -lXXXXXX arguments. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
Diffstat (limited to 'sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild')
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
index 14e1fabda..68341a338 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -36,11 +36,12 @@ KEYWORDS="~amd64"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# sys-libs/db should be compiled with USE=cxx
+# dev-libs/boost must have Boost.Test suite, probably dev-libs/boost[test] then?
DEPEND="
!sci-biology/sra_sdk
app-arch/cpio
berkdb? ( sys-libs/db:4.3[cxx] )
- boost? ( dev-libs/boost )
+ boost? ( dev-libs/boost[tools] )
curl? ( net-misc/curl )
sqlite? ( dev-db/sqlite:3 )
mysql? ( virtual/mysql )