aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheChymera <h.chr@mail.ru>2013-01-18 22:37:20 +0000
committerTheChymera <h.chr@mail.ru>2013-01-18 22:37:20 +0000
commit00ebb8da95fa7ad68e53db499307ca004b01e93a (patch)
tree97b874b811271c8c5c04d50f60439c3087e1aaaf /sci-biology
parentFperms instead of Chmod (diff)
downloadsci-00ebb8da95fa7ad68e53db499307ca004b01e93a.tar.gz
sci-00ebb8da95fa7ad68e53db499307ca004b01e93a.tar.bz2
sci-00ebb8da95fa7ad68e53db499307ca004b01e93a.zip
Added src_install() script to make a launcher and assign an icon to it.
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/psychopy/psychopy-1.75.01.ebuild9
-rw-r--r--sci-biology/psychopy/psychopy-9999.ebuild11
2 files changed, 9 insertions, 11 deletions
diff --git a/sci-biology/psychopy/psychopy-1.75.01.ebuild b/sci-biology/psychopy/psychopy-1.75.01.ebuild
index f9e02b6a0..83f628756 100644
--- a/sci-biology/psychopy/psychopy-1.75.01.ebuild
+++ b/sci-biology/psychopy/psychopy-1.75.01.ebuild
@@ -42,9 +42,8 @@ RESTRICT="test" # interactive, opens lots of windows
S="${WORKDIR}/${MY_P}"
-python_install() {
- distutils-r1_python_install
- #local EPYTHON=python2.7
- #die $(sh -c 'echo $EPYTHON')
- fperms +x "$(python_get_sitedir)/psychopy/app/psychopyApp.py" || die "chmod of psychopyApp.py failed"
+src_install() {
+ distutils-r1_src_install
+ doicon psychopy/monitors/psychopy.ico
+ make_desktop_entry psychopyapp.py PsychoPy psychopy "Science;Biology"
}
diff --git a/sci-biology/psychopy/psychopy-9999.ebuild b/sci-biology/psychopy/psychopy-9999.ebuild
index 03b74d457..ff224d97a 100644
--- a/sci-biology/psychopy/psychopy-9999.ebuild
+++ b/sci-biology/psychopy/psychopy-9999.ebuild
@@ -9,7 +9,7 @@ inherit eutils distutils-r1 git-2
DESCRIPTION="Python experiemntal psychology toolkit"
HOMEPAGE="http://www.psychopy.org/"
-EGIT_REPO_URI="https://github.com/psychopy/psychopy"
+EGIT_REPO_URI="https://github.com/TheChymera/psychopy.git"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -28,9 +28,8 @@ RDEPEND="${DEPEND}
dev-python/wxpython
sci-libs/scipy"
-python_install() {
- distutils-r1_python_install
- #local EPYTHON=python2.7
- #die $(sh -c 'echo $EPYTHON')
- fperms +x "$(python_get_sitedir)/psychopy/app/psychopyApp.py" || die "chmod of psychopyApp.py failed"
+src_install() {
+ distutils-r1_src_install
+ doicon psychopy/monitors/psychopy.ico
+ make_desktop_entry psychopyapp.py PsychoPy psychopy "Science;Biology"
}