aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-03-18 17:33:18 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-03-18 17:33:18 +0100
commit2cf8dc31a6d127404c269bcd56d5e3ae96f823e2 (patch)
treebb06de3c2c9d9d45d27ba9ec17a331d326421a86 /sci-biology
parentsci-biology/scythe: improve DESCRIPTION (diff)
downloadsci-2cf8dc31a6d127404c269bcd56d5e3ae96f823e2.tar.gz
sci-2cf8dc31a6d127404c269bcd56d5e3ae96f823e2.tar.bz2
sci-2cf8dc31a6d127404c269bcd56d5e3ae96f823e2.zip
sci-biology/consed: fix the autogenerated /etc/env.d/ file and make sure the EPREFIX is expanded in it (should be also fixed in consed-27 in the main gentoo repo), check yourself 'printenv | grep CONSED' and do not forger env-update && . /etc/profile before re-testing; the first part of the patch now properly edits the variable in perl-based scripts/*; however, I am still getting some issue with 'consed -ace 454Contigs.ace.1 -fixContigEnds' giving me:\nabout to run: /usr/bin/fixContigEnd.perl right_contig00004|m.2.ref_160318.171619.fasta right_contig00004|m.2.ref_160318.171619.fixConsensusEndAceFile.fof\nUse of uninitialized value [1] in string eq at /usr/bin/fixContigEnd.perl line 21.\nsh: m.2.ref_160318.171619.fasta: command not found\nsh: m.2.ref_160318.171619.fixConsensusEndAceFile.fof: command not found\n
Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/consed/consed-29.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-biology/consed/consed-29.ebuild b/sci-biology/consed/consed-29.ebuild
index 46144771b..0a8387c0d 100644
--- a/sci-biology/consed/consed-29.ebuild
+++ b/sci-biology/consed/consed-29.ebuild
@@ -48,12 +48,12 @@ src_prepare() {
-e 's#/me1/gordon/samtools/samtools-0.1.18#/usr/include/bam/ -I/usr/include/htslib/#' "${S}/makefile" || die
sed -i -e 's/CFLAGS=/CFLAGS += /' "${S}"/misc/*/Makefile || die
sed \
- -e 's!\($szPhredParameterFile =\).*!\1 $ENV{PHRED_PARAMETER_FILE} || "'${EPREFIX}'/usr/share/phred/phredpar.dat";!' \
+ -e "s!\$szPhredParameterFile = .*!\$szPhredParameterFile = \$ENV{'PHRED_PARAMETER_FILE'} || \'"${EPREFIX}"/usr/share/phred/phredpar.dat\';!" \
-i "${S}"/scripts/* || die
}
src_compile() {
- einfo "consed does not compile with sys-devel/gcc-4.6:* or newer (but 4.4.7 works)"
+ einfo "consed does not compile with >=sys-devel/gcc-4.6:* but 4.4.7 works"
default
emake -C misc/mktrace
emake -C misc/phd2fasta
@@ -70,8 +70,8 @@ src_install() {
standard polyphred autofinish assembly_view 454_newbler \
align454reads align454reads_answer solexa_example \
solexa_example_answer selectRegions selectRegionsAnswer
- echo 'CONSED_HOME="${EPREFIX}/usr"' > "${S}"/99consed || die
- echo 'CONSED_PARAMETERS="${EPREFIX}/etc/consedrc"' >> "${S}"/99consed || die
+ echo CONSED_HOME="${EPREFIX}"/usr > "${S}"/99consed || die
+ echo CONSED_PARAMETERS="${EPREFIX}"/etc/consedrc >> "${S}"/99consed || die
mkdir -p "${ED}"/etc/consedrc || die
touch "${ED}"/etc/consedrc || die
doenvd "${S}/99consed"