aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-05-14 20:48:46 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-05-14 20:48:46 +0200
commit4036ac0a6d0616ae423c7de5f5f6dfc60bd83e6f (patch)
tree5e2fe154531d58cba818446c72442e795348af7e /sci-biology
parentsci-biology/SPAdes: install the package directly using cmake (diff)
downloadsci-4036ac0a6d0616ae423c7de5f5f6dfc60bd83e6f.tar.gz
sci-4036ac0a6d0616ae423c7de5f5f6dfc60bd83e6f.tar.bz2
sci-4036ac0a6d0616ae423c7de5f5f6dfc60bd83e6f.zip
sci-biology/SPAdes: drop DEPENDency on boost
Upstream says SPAdes uses bundled while modified local copy. Fix URL to new official site. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/SPAdes/SPAdes-3.10.1.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sci-biology/SPAdes/SPAdes-3.10.1.ebuild b/sci-biology/SPAdes/SPAdes-3.10.1.ebuild
index de93157a4..a887fe909 100644
--- a/sci-biology/SPAdes/SPAdes-3.10.1.ebuild
+++ b/sci-biology/SPAdes/SPAdes-3.10.1.ebuild
@@ -5,10 +5,10 @@ EAPI=6
PYTHON_COMPAT=( python{2_7,3_{4,5}} )
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs cmake-utils
DESCRIPTION="De novo de Bruijn genome assembler overcoming uneven coverage"
-HOMEPAGE="http://bioinf.spbau.ru/en/spades"
+HOMEPAGE="http://cab.spbu.ru/software/spades"
SRC_URI="
http://spades.bioinf.spbau.ru/release${PV}/SPAdes-${PV}.tar.gz
http://spades.bioinf.spbau.ru/release${PV}/manual.html -> ${P}_manual.html
@@ -24,10 +24,11 @@ IUSE=""
DEPEND="
sys-libs/zlib
app-arch/bzip2
- dev-python/regex
- dev-libs/boost"
+ dev-python/regex"
RDEPEND="${DEPEND}"
-
+# BUG:
+# SPAdes uses bundled while modified copy of dev-libs/boost
+#
# BUG: "${S}"/ext/src/ contains plenty of bundled 3rd-party tools. Drop them all and properly DEPEND on their
# existing packages
# nlopt
@@ -44,7 +45,7 @@ RDEPEND="${DEPEND}"
# samtools
# bwa
-# BUG: "${S}"/ext/tools/ contains even two version of bwa
+# BUG: "${S}"/ext/tools/ contains even two version of bwa, being installed as bwa-spades binary?
# bwa-0.7.12
# bwa-0.6.2
@@ -76,6 +77,7 @@ src_compile(){
src_install(){
cd build_spades || die
emake install PREFIX="${ED}"/usr
+ # cmake-utils_src_install # dies with "${S}" does not appear to contain CMakeLists.txt
# BUG: move *.py files to standard site-packages/ subdirectories
insinto /usr/share/"${PN}"
dodoc "${DISTDIR}"/${P}_*manual.html