aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2013-09-03 15:46:31 -0700
committerSébastien Fabbro <sebfabbro@gmail.com>2013-09-03 15:46:31 -0700
commit5e86d06ab1f3a19eb7e171f94c35d2d80d1c27fa (patch)
treebe2d8077ce06992748e10c8388d8f74057180841 /sci-biology
parentMerge pull request #105 from jhcloos/sfst (diff)
parentListed app-admin/eselect under DEP only (instead of RDEP) (diff)
downloadsci-5e86d06ab1f3a19eb7e171f94c35d2d80d1c27fa.tar.gz
sci-5e86d06ab1f3a19eb7e171f94c35d2d80d1c27fa.tar.bz2
sci-5e86d06ab1f3a19eb7e171f94c35d2d80d1c27fa.zip
Merge pull request #104 from TheChymera/psychopy
New, updated Psychopy ebuilds
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/psychopy/Manifest2
-rw-r--r--sci-biology/psychopy/psychopy-1.75.01.ebuild12
-rw-r--r--sci-biology/psychopy/psychopy-1.77.02.ebuild56
-rw-r--r--sci-biology/psychopy/psychopy-1.78.00.ebuild56
-rw-r--r--sci-biology/psychopy/psychopy-9999.ebuild12
5 files changed, 128 insertions, 10 deletions
diff --git a/sci-biology/psychopy/Manifest b/sci-biology/psychopy/Manifest
index ced74875f..c306e0274 100644
--- a/sci-biology/psychopy/Manifest
+++ b/sci-biology/psychopy/Manifest
@@ -1 +1,3 @@
DIST PsychoPy-1.75.01.zip 3512277 SHA256 c86c617bcd9a215f1fe3d1420563a9bc1c8c6707b477481f885437a68a56d211 SHA512 3a57dcff426d9bbeeababd7699d2fe99fc36025d45b4f52abb8ae4544454314dacb00b52b16f94168c86a255f9ac469fad297590b6e466931d5de12e7520f684 WHIRLPOOL a0f258c293937efbd6cbbc325663a1de93961de349e0113562c20d54a957c686590256d7c7a2e0ebea7a497090569ba0e2b777165e9cfe908af82a90991bb939
+DIST PsychoPy-1.77.02.zip 6313389 SHA256 37313ca13e6062146979dbc79dde79306377a08958b47ea1477957373914f1a1 SHA512 11c305d69763c7eca236c53ccef56780637ad2d53801764dada52565a4e07949422722cf7d8691b615d515c6eeee1c29e2ec44fc312fb299fc2bea17b5a15b44 WHIRLPOOL 568cd06a9ad511ceeb0f0293296d4a98549855960be82e25de57b576bbf6614f37253358dcc44909570a73b298df0651920ab2378e0145eb8bd69186922a745c
+DIST PsychoPy-1.78.00.zip 6376071 SHA256 ac74ea948f400a4a962a6abde7e7360fce5738a0f44aec4a0ff636d00976cc25 SHA512 ec2cd1c2094488d2b02c94070c7bc3d50e12e597c0107d2f64d49522e43a12c81b060b7a8abc15e83d50736776ee9d3d7190b78d39c58ee8f8be88b32330c5e2 WHIRLPOOL 9395a55bb820d2d326f4d95e12fb7513fbc4038eea25d0fd182e7e909e86d153374ac14293e89162761f0655b14bb8ca2abfa7fdf3df3e1951bec11e469db1f7
diff --git a/sci-biology/psychopy/psychopy-1.75.01.ebuild b/sci-biology/psychopy/psychopy-1.75.01.ebuild
index f4469cee4..db7ffd360 100644
--- a/sci-biology/psychopy/psychopy-1.75.01.ebuild
+++ b/sci-biology/psychopy/psychopy-1.75.01.ebuild
@@ -28,13 +28,15 @@ RDEPEND="
dev-python/wxpython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- app-admin/eselect
dev-python/pyglet[${PYTHON_USEDEP}]
- dev-python/pygame[${PYTHON_USEDEP}]"
+ dev-python/pygame[${PYTHON_USEDEP}]
+ "
-DEPEND="app-arch/unzip
+DEPEND="app-admin/eselect
+ app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
+ test? ( ${RDEPEND} )
+ "
RESTRICT="test" # interactive, opens lots of windows
@@ -43,7 +45,7 @@ S="${WORKDIR}/${MY_P}"
python_install_all() {
distutils-r1_python_install_all
doicon psychopy/monitors/psychopy.ico
- make_desktop_entry psychopyapp.py PsychoPy psychopy "Science;Biology"
+ make_desktop_entry psychopyapp.py PsychoPy psychopy
}
pkg_postinst() {
diff --git a/sci-biology/psychopy/psychopy-1.77.02.ebuild b/sci-biology/psychopy/psychopy-1.77.02.ebuild
new file mode 100644
index 000000000..db7ffd360
--- /dev/null
+++ b/sci-biology/psychopy/psychopy-1.77.02.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils eutils
+
+MY_P="PsychoPy-${PV}"
+
+DESCRIPTION="Python experimental psychology toolkit"
+HOMEPAGE="http://www.psychopy.org/"
+SRC_URI="http://psychopy.googlecode.com/files/${MY_P}.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[lapack,${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ "
+
+DEPEND="app-admin/eselect
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ "
+
+RESTRICT="test" # interactive, opens lots of windows
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doicon psychopy/monitors/psychopy.ico
+ make_desktop_entry psychopyapp.py PsychoPy psychopy
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/sci-biology/psychopy/psychopy-1.78.00.ebuild b/sci-biology/psychopy/psychopy-1.78.00.ebuild
new file mode 100644
index 000000000..584a533a9
--- /dev/null
+++ b/sci-biology/psychopy/psychopy-1.78.00.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils eutils
+
+MY_P="PsychoPy-${PV}"
+
+DESCRIPTION="Python experimental psychology toolkit"
+HOMEPAGE="http://www.psychopy.org/"
+SRC_URI="http://sourceforge.net/projects/psychpy/files/PsychoPy/${MY_P}.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[lapack,${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ "
+
+DEPEND="app-admin/eselect
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ "
+
+RESTRICT="test" # interactive, opens lots of windows
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doicon psychopy/monitors/psychopy.ico
+ make_desktop_entry psychopyapp.py PsychoPy psychopy
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/sci-biology/psychopy/psychopy-9999.ebuild b/sci-biology/psychopy/psychopy-9999.ebuild
index cc0241660..512d34757 100644
--- a/sci-biology/psychopy/psychopy-9999.ebuild
+++ b/sci-biology/psychopy/psychopy-9999.ebuild
@@ -14,12 +14,13 @@ EGIT_REPO_URI="https://github.com/psychopy/psychopy.git"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-admin/eselect
+ "
RDEPEND="${DEPEND}
- app-admin/eselect
virtual/python-imaging[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
@@ -28,12 +29,13 @@ RDEPEND="${DEPEND}
dev-python/pyglet[${PYTHON_USEDEP}]
dev-python/pyopengl[${PYTHON_USEDEP}]
dev-python/wxpython[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]"
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
python_install_all() {
distutils-r1_python_install_all
newicon -s scalable psychopy/monitors/psychopy-icon.svg psychopy.svg
- make_desktop_entry psychopyApp.py PsychoPy psychopy "Science;Biology"
+ make_desktop_entry psychopyApp.py PsychoPy psychopy
}
pkg_postinst() {