aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-18 14:29:11 +0100
committerJustin Lecher <jlec@gentoo.org>2015-02-18 14:29:11 +0100
commitabea2757044d9b4ee86ceea1a0f6afe974c03f62 (patch)
tree62ca442a2e381578776f958aa4f0da2da3366530 /sci-biology
parentsci-biology/ncbi-blast+: fix SLOT operators; correct python deps (diff)
downloadsci-abea2757044d9b4ee86ceea1a0f6afe974c03f62.tar.gz
sci-abea2757044d9b4ee86ceea1a0f6afe974c03f62.tar.bz2
sci-abea2757044d9b4ee86ceea1a0f6afe974c03f62.zip
sci-biology/ncbi-tools++: fix SLOT operators; correct python deps
Package-Manager: portage-2.2.17
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/ncbi-tools++/ChangeLog5
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild18
2 files changed, 15 insertions, 8 deletions
diff --git a/sci-biology/ncbi-tools++/ChangeLog b/sci-biology/ncbi-tools++/ChangeLog
index 65f0990cc..44abaa213 100644
--- a/sci-biology/ncbi-tools++/ChangeLog
+++ b/sci-biology/ncbi-tools++/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-biology/ncbi-tools++
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 18 Feb 2015; Justin Lecher <jlec@gentoo.org> ncbi-tools++-12.0.0.ebuild:
+ sci-biology/ncbi-tools++: fix SLOT operators; correct python deps
+
16 Sep 2014; Christoph Junghans <ottxor@gentoo.org>
-files/ncbi-tools++-12.0.0-as-needed.patch,
-files/ncbi-tools++-9.0.0-as-needed.patch,
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
index b019bc6c8..b2933a43a 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-inherit eutils flag-o-matic multilib toolchain-funcs
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic multilib python-single-r1 toolchain-funcs
MY_TAG="Jun_15_2010"
MY_Y="${MY_TAG/*_/}"
@@ -31,13 +33,15 @@ IUSE="
#KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
KEYWORDS=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
# sys-libs/db should be compiled with USE=cxx
DEPEND="
!sci-biology/sra_sdk
berkdb? ( sys-libs/db:4.3[cxx] )
boost? ( dev-libs/boost )
curl? ( net-misc/curl )
- sqlite? ( dev-db/sqlite )
+ sqlite? ( dev-db/sqlite:0 )
sqlite3? ( dev-db/sqlite:3 )
mysql? ( virtual/mysql )
fltk? ( x11-libs/fltk )
@@ -47,7 +51,7 @@ DEPEND="
freetype? ( media-libs/freetype )
fastcgi? ( www-apache/mod_fastcgi )
gnutls? ( net-libs/gnutls )
- python? ( dev-lang/python )
+ python? ( ${PYTHON_DEPS} )
cppunit? ( dev-util/cppunit )
icu? ( dev-libs/icu )
expat? ( dev-libs/expat )
@@ -59,9 +63,9 @@ DEPEND="
muparser? ( dev-cpp/muParser )
hdf5? ( sci-libs/hdf5[cxx] )
gif? ( media-libs/giflib )
- jpeg? ( virtual/jpeg )
- png? ( media-libs/libpng )
- tiff? ( media-libs/tiff )
+ jpeg? ( virtual/jpeg:0= )
+ png? ( media-libs/libpng:0= )
+ tiff? ( media-libs/tiff:0= )
xpm? ( x11-libs/libXpm )
dev-libs/lzo
app-arch/bzip2