aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@gmail.com>2020-05-06 19:44:42 +0200
committerMartin Mokrejs <mmokrejs@gmail.com>2020-05-06 19:44:49 +0200
commitae5eb7ca6ede7e8579ade25afb8eb005c62ee35a (patch)
tree381ab41403530ce005a19fb93c07b82cea99e5f7 /sci-biology
parentsci-libs/mkl: version bump to 2020 update 1 (diff)
downloadsci-ae5eb7ca6ede7e8579ade25afb8eb005c62ee35a.tar.gz
sci-ae5eb7ca6ede7e8579ade25afb8eb005c62ee35a.tar.bz2
sci-ae5eb7ca6ede7e8579ade25afb8eb005c62ee35a.zip
sci-biology/pybedtools: update homepage, explicitly run cythonize
Package-Manager: Portage-2.3.95, Repoman-2.3.22 Signed-off-by: Martin Mokrejs <mmokrejs@gmail.com>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/pybedtools/pybedtools-0.8.0.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/sci-biology/pybedtools/pybedtools-0.8.0.ebuild b/sci-biology/pybedtools/pybedtools-0.8.0.ebuild
index d817a594f..cd444a09e 100644
--- a/sci-biology/pybedtools/pybedtools-0.8.0.ebuild
+++ b/sci-biology/pybedtools/pybedtools-0.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
inherit distutils-r1
DESCRIPTION="Use BED and GFF files from python using BEDtools"
-HOMEPAGE="http://pythonhosted.org/pybedtools/"
+HOMEPAGE="https://daler.github.io/pybedtools"
SRC_URI="https://github.com/daler/pybedtools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
@@ -16,6 +16,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND="sci-biology/bedtools"
+RDEPEND="
+ sci-biology/bedtools
+ sci-biology/pysam"
DEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]"
+
+src_compile(){
+ python setup.py cythonize
+ default
+}