aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-06-25 03:10:25 +0200
committerHorea Christian <horea.christ@yandex.com>2018-06-25 03:22:05 +0200
commitd361c9c4a2380e2f918740463206ca430fe60e24 (patch)
treeadadc662b3488af6c5cc0fa51324aef1776d5e94 /sci-biology
parentsci-biology/salmon: bump version of required dev-cpp/tbb (diff)
downloadsci-d361c9c4a2380e2f918740463206ca430fe60e24.tar.gz
sci-d361c9c4a2380e2f918740463206ca430fe60e24.tar.bz2
sci-d361c9c4a2380e2f918740463206ca430fe60e24.zip
sci-biology/afni: new package
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/afni/Manifest1
-rw-r--r--sci-biology/afni/afni-18.1.04.ebuild68
-rw-r--r--sci-biology/afni/afni-9999.ebuild69
-rw-r--r--sci-biology/afni/metadata.xml16
4 files changed, 154 insertions, 0 deletions
diff --git a/sci-biology/afni/Manifest b/sci-biology/afni/Manifest
new file mode 100644
index 000000000..3e93e8aa6
--- /dev/null
+++ b/sci-biology/afni/Manifest
@@ -0,0 +1 @@
+DIST afni-18.1.04.tar.gz 196776384 BLAKE2B 389c2dcf11bf3e3d067cbe1cce772a299b6f9096e21936616893041f72b2d3f490b3bed6ef10d94dd5f7c08436206379339a05384ac005349f55d40bb241e695 SHA512 16151d2512d115a2e4531932cbfd50cb1cf6c2e5c809d91fb439495d7d62f2d50f05f5f411395af0cc24e9a34bf8e98efd389b9e50bc75f783e051e7ab3db121
diff --git a/sci-biology/afni/afni-18.1.04.ebuild b/sci-biology/afni/afni-18.1.04.ebuild
new file mode 100644
index 000000000..3a646ffb7
--- /dev/null
+++ b/sci-biology/afni/afni-18.1.04.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib pax-utils toolchain-funcs
+
+DESCRIPTION="An open-source environment for processing and displaying functional MRI data"
+HOMEPAGE="http://afni.nimh.nih.gov/"
+SRC_URI="https://github.com/afni/afni/archive/AFNI_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/expat
+ media-libs/netpbm
+ media-libs/qhull
+ media-video/mpeg-tools
+ sci-libs/gsl
+ sys-devel/llvm:*
+ virtual/jpeg:0
+ x11-libs/libGLw
+ x11-libs/libXft
+ x11-libs/libXi
+ x11-libs/libXpm
+ x11-libs/motif[-static-libs]"
+
+# x11-libs/motif[static-libs] breaks the build.
+# See upstream discussion
+# http://afni.nimh.nih.gov/afni/community/board/read.php?1,85348,85348#msg-85348
+
+DEPEND="${RDEPEND}
+ app-shells/tcsh"
+
+S="${WORKDIR}/${PN}-AFNI_${PV}/src"
+BUILD="linux_fedora_19_64"
+BIN_CONFLICTS=(qdelaunay whirlgif djpeg cjpeg qhull rbox count mpeg_encode)
+
+src_prepare() {
+ find -type f -exec sed -i -e "s/-lXp //g" {} +
+ cp other_builds/Makefile.${BUILD} Makefile || die "Could not copy Makefile"
+ sed -e "s~CC = /usr/bin/gcc -O2 -m64~CC = $(tc-getCC) \$(CFLAGS)~" \
+ -e "s~CCMIN = /usr/bin/gcc -m64~CCMIN = $(tc-getCC) \$(CFLAGS)~" \
+ -e "s~LD = /usr/bin/gcc~LD = $(tc-getCC)~" \
+ -e "s~AR = /usr/bin/ar~AR = $(tc-getAR)~" \
+ -e "s~RANLIB = /usr/bin/ranlib~RANLIB = $(tc-getRANLIB)~" \
+ -i Makefile || die "Could not edit Makefile"
+ # they provide somewhat problematic makefiles :(
+ sed -e "s~ifeq ($(CC),gcc)~ifeq (1,1)~"\
+ -i SUMA/SUMA_Makefile || die "Could not edit SUMA/SUMA_Makefile"
+ # upstream checks if $CC is EXACTLY gcc, else sets variables for Mac
+ find "${S}" -iname "*Makefile*" | xargs sed -e "s~/usr/~${EROOT}/usr/~g;" -i
+ eapply_user
+}
+
+src_compile() {
+ emake -j1 all plugins suma_exec
+}
+
+src_install() {
+ emake INSTALLDIR="${ED}/usr/bin" -j1 install install_plugins
+ emake INSTALLDIR="${ED}/usr/$(get_libdir)" -j1 install_lib
+ for CONFLICT in ${BIN_CONFLICTS[@]}; do
+ rm "${ED}/usr/bin/${CONFLICT}"
+ done
+}
diff --git a/sci-biology/afni/afni-9999.ebuild b/sci-biology/afni/afni-9999.ebuild
new file mode 100644
index 000000000..e73bef8cc
--- /dev/null
+++ b/sci-biology/afni/afni-9999.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib pax-utils git-r3 toolchain-funcs
+
+DESCRIPTION="An open-source environment for processing and displaying functional MRI data"
+HOMEPAGE="http://afni.nimh.nih.gov/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/AFNI/AFNI"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-libs/expat
+ media-libs/netpbm
+ media-libs/qhull
+ media-video/mpeg-tools
+ sci-libs/gsl
+ sys-devel/llvm:*
+ virtual/jpeg:0
+ x11-libs/libGLw
+ x11-libs/libXft
+ x11-libs/libXi
+ x11-libs/libXpm
+ x11-libs/motif[-static-libs]"
+
+# x11-libs/motif[static-libs] breaks the build.
+# See upstream discussion
+# http://afni.nimh.nih.gov/afni/community/board/read.php?1,85348,85348#msg-85348
+
+DEPEND="${RDEPEND}
+ app-shells/tcsh"
+
+S="${WORKDIR}/${P}/src"
+BUILD="linux_fedora_19_64"
+BIN_CONFLICTS=(qdelaunay whirlgif djpeg cjpeg qhull rbox count mpeg_encode)
+
+src_prepare() {
+ find -type f -exec sed -i -e "s/-lXp //g" {} +
+ cp other_builds/Makefile.${BUILD} Makefile || die "Could not copy Makefile"
+ sed -e "s~CC = /usr/bin/gcc -O2 -m64~CC = $(tc-getCC) \$(CFLAGS)~" \
+ -e "s~CCMIN = /usr/bin/gcc -m64~CCMIN = $(tc-getCC) \$(CFLAGS)~" \
+ -e "s~LD = /usr/bin/gcc~LD = $(tc-getCC)~" \
+ -e "s~AR = /usr/bin/ar~AR = $(tc-getAR)~" \
+ -e "s~RANLIB = /usr/bin/ranlib~RANLIB = $(tc-getRANLIB)~" \
+ -i Makefile || die "Could not edit Makefile"
+ # they provide somewhat problematic makefiles :(
+ sed -e "s~ifeq ($(CC),gcc)~ifeq (1,1)~"\
+ -i SUMA/SUMA_Makefile || die "Could not edit SUMA/SUMA_Makefile"
+ # upstream checks if $CC is EXACTLY gcc, else sets variables for Mac
+ find "${S}" -iname "*Makefile*" | xargs sed -e "s~/usr/~${EROOT}/usr/~g;" -i
+ eapply_user
+}
+
+src_compile() {
+ emake -j1 all plugins suma_exec
+}
+
+src_install() {
+ emake INSTALLDIR="${ED}/usr/bin" -j1 install install_plugins
+ emake INSTALLDIR="${ED}/usr/$(get_libdir)" -j1 install_lib
+ for CONFLICT in ${BIN_CONFLICTS[@]}; do
+ rm "${ED}/usr/bin/${CONFLICT}"
+ done
+}
diff --git a/sci-biology/afni/metadata.xml b/sci-biology/afni/metadata.xml
new file mode 100644
index 000000000..0923769c1
--- /dev/null
+++ b/sci-biology/afni/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ Analysis of Functional NeuroImages (AFNI) is an open-source environment for processing and displaying
+ functional MRI data—a technique for mapping human brain activity.
+ </longdescription>
+</pkgmetadata>