aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-01-10 14:29:21 +0100
committerJustin Lecher <jlec@gentoo.org>2015-01-10 14:29:21 +0100
commite9a2b3ddeae5c85652ba3c6758a00a7f22d9203c (patch)
tree8253e2d7b6bd0d6d8a75d42e1b7ea695751bc714 /sci-biology
parentUpdate dev-db/postgresql-base to dev-db/postgresql (diff)
downloadsci-e9a2b3ddeae5c85652ba3c6758a00a7f22d9203c.tar.gz
sci-e9a2b3ddeae5c85652ba3c6758a00a7f22d9203c.tar.bz2
sci-e9a2b3ddeae5c85652ba3c6758a00a7f22d9203c.zip
sci-biology/BRANCH: Move from git-2 to git-r3 eclass; add HOMEPAGE; be verbose during compilation; install docs
Package-Manager: portage-2.2.15
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/BRANCH/BRANCH-9999.ebuild15
-rw-r--r--sci-biology/BRANCH/ChangeLog4
2 files changed, 12 insertions, 7 deletions
diff --git a/sci-biology/BRANCH/BRANCH-9999.ebuild b/sci-biology/BRANCH/BRANCH-9999.ebuild
index 74be1b12e..923f5b467 100644
--- a/sci-biology/BRANCH/BRANCH-9999.ebuild
+++ b/sci-biology/BRANCH/BRANCH-9999.ebuild
@@ -4,12 +4,12 @@
EAPI=5
-[ "$PV" == "9999" ] && inherit git-2
+[ "$PV" == "9999" ] && inherit git-r3
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Extend partial transcripts with sequence from other reads or genomic contigs"
-HOMEPAGE=""
+HOMEPAGE="https://github.com/baoe/BRANCH"
if [ "$PV" == "9999" ]; then
EGIT_REPO_URI="https://github.com/baoe/BRANCH"
KEYWORDS=""
@@ -18,20 +18,21 @@ else
KEYWORDS=""
fi
-
LICENSE="Artistic-2"
SLOT="0"
IUSE=""
-DEPEND="sci-biology/blat
+DEPEND="
+ sci-biology/blat
sci-libs/lemon"
RDEPEND="${DEPEND}"
src_compile(){
- cd BRANCH || die
- g++ -o BRANCH BRANCH.cpp -lemon -lpthread || die
+ einfo "$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -o BRANCH BRANCH.cpp -lemon -lpthread"
+ $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -o BRANCH/BRANCH BRANCH/BRANCH.cpp -lemon -lpthread || die
}
src_install(){
dobin BRANCH/BRANCH
+ dodoc README.md
}
diff --git a/sci-biology/BRANCH/ChangeLog b/sci-biology/BRANCH/ChangeLog
index 8954ba6d4..03ab1fc78 100644
--- a/sci-biology/BRANCH/ChangeLog
+++ b/sci-biology/BRANCH/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 10 Jan 2015; Justin Lecher <jlec@gentoo.org> BRANCH-9999.ebuild:
+ Move from git-2 to git-r3 eclass; add HOMEPAGE; be verbose during
+ compilation; install docs
+
*BRANCH-9999 (07 Jan 2015)
07 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>