aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorje_fro <je_fro@32389bae-6d03-0410-99cf-db05cde120eb>2008-09-30 03:44:22 +0000
committerje_fro <je_fro@32389bae-6d03-0410-99cf-db05cde120eb>2008-09-30 03:44:22 +0000
commit30fde7b3622dc7f8c7d3cdd445cd04834af57e26 (patch)
tree648f20731c29988882753b461526aad2c72e9048 /sci-chemistry/modeller
parentBump first batch of octave-forge packages to new revision. (diff)
downloadsci-30fde7b3622dc7f8c7d3cdd445cd04834af57e26.tar.gz
sci-30fde7b3622dc7f8c7d3cdd445cd04834af57e26.tar.bz2
sci-30fde7b3622dc7f8c7d3cdd445cd04834af57e26.zip
latest version
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1302 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-chemistry/modeller')
-rw-r--r--sci-chemistry/modeller/Manifest2
-rw-r--r--sci-chemistry/modeller/modeller-9.4.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/sci-chemistry/modeller/Manifest b/sci-chemistry/modeller/Manifest
index 942e125c2..927ef14db 100644
--- a/sci-chemistry/modeller/Manifest
+++ b/sci-chemistry/modeller/Manifest
@@ -1,3 +1,5 @@
DIST modeller-9v3.tar.gz 49912561 RMD160 9472bc951faa8e4a28b0834c58aa0d7100492412 SHA1 5f7589536923a9504ad52430fabf8dfc49dde3b1 SHA256 b70052c1fae18f4cba598ce15d3cfd46c2c0df10d23e066a65aceea59063f3ae
+DIST modeller-9v4.tar.gz 49949423 RMD160 1dc1b97099708ce79055ec6496155c7e27a3efb1 SHA1 2d1432782714b54b01190e9ef4fc9bb454210a23 SHA256 c291ad617b3bd697e5bd5efede00d9869bb019d0a60d26344617fafa82b3d779
EBUILD modeller-9.3.ebuild 3086 RMD160 601b9b157895bcc549f51896b7a54a1bdf781802 SHA1 f620485a171de556a1dbdf10eccfa43f0e719f2b SHA256 26c381d12306018356ae3a97cc708ece970bcf07e77914026f0192119cf80649
+EBUILD modeller-9.4.ebuild 3086 RMD160 32088000bb7a7f7cba8b8e7a088f737cd6991f61 SHA1 077a0dd6cc9b766ed5d1f8589e356d86881fddba SHA256 9024d2e52616b56aba52ab2cecddf94ba4881a46067f6807d4258880b9be08b9
MISC ChangeLog 366 RMD160 c8e3df06513eba7af76d56f3f023881cbb7556f2 SHA1 40d13fa7a97a6fb959793c42be6afdb61e9dace8 SHA256 7aebd9473568ad2f12d41d4241479ed163cbed2eb116be1772f80eb08f5214d4
diff --git a/sci-chemistry/modeller/modeller-9.4.ebuild b/sci-chemistry/modeller/modeller-9.4.ebuild
new file mode 100644
index 000000000..b144ffeeb
--- /dev/null
+++ b/sci-chemistry/modeller/modeller-9.4.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils python
+
+MY_PV="${PV/./v}"
+LICENSE="modeller"
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="MODELLER is used for homology or comparative modeling of protein three-dimensional structures"
+SRC_URI="http://salilab.org/${PN}/${MY_PV}/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://salilab.org/${PN}/"
+IUSE=""
+RESTRICT="mirror"
+SLOT="0"
+
+RDEPEND=">=dev-lang/python-2.4"
+DEPEND=""
+
+src_install(){
+ python_version
+
+ VER=9v4
+ case ${ARCH} in
+ x86) EXECUTABLE_TYPE="i386-intel8";;
+ amd64) EXECUTABLE_TYPE="x86_64-intel8";;
+ *) ewarn "Your arch "${ARCH}" does not appear supported at this time."||\
+ die "Unsupported Arch";;
+ esac
+
+ IN_PATH=/opt/modeller${VER}
+
+ sed -e "s:EXECUTABLE_TYPE${VER}=xxx:EXECUTABLE_TYPE${VER}=${EXECUTABLE_TYPE}:g" \
+ -e "s:MODINSTALL${VER}=xxx:MODINSTALL${VER}=\"${IN_PATH}\":g" \
+ modeller-${VER}/bin/modscript > "${T}/mod${VER}"
+ exeinto ${IN_PATH}/bin/
+ doexe "${T}/mod${VER}"
+ dosym ${IN_PATH}/bin/mod${VER} /opt/bin/mod${VER}
+
+ sed -e "s;@TOPDIR\@;\"${IN_PATH}\";" \
+ -e "s;@EXETYPE\@;$EXECUTABLE_TYPE;" \
+ modeller-${VER}/bin/modpy.sh.in > "${T}/modpy.sh"
+ doexe "${T}/modpy.sh"
+
+ insinto ${IN_PATH}/bin/
+ doins -r modeller-${VER}/bin/{*top,lib}
+ exeinto ${IN_PATH}/bin/
+ doexe modeller-${VER}/bin/{modslave.py,mod${VER}_${EXECUTABLE_TYPE}}
+
+ exeinto /usr/lib/python${PYVER}/site-packages/
+ doexe modeller-${VER}/lib/${EXECUTABLE_TYPE}/_modeller.so
+ dosym ${IN_PATH}/modlib/modeller /usr/lib/python${PYVER}/site-packages/modeller
+ dosym ${IN_PATH}/lib/${EXECUTABLE_TYPE}/_modeller.so\
+ /usr/lib/python${PYVER}/site-packages/_modeller.so
+
+ exeinto ${IN_PATH}/lib/${EXECUTABLE_TYPE}/
+ doexe modeller-${VER}/lib/${EXECUTABLE_TYPE}/{lib*,_modeller.so}
+ exeinto ${IN_PATH}/lib/${EXECUTABLE_TYPE}/python${PYVER}/
+ doexe modeller-${VER}/lib/${EXECUTABLE_TYPE}/python2.5/_modeller.so
+ dosym ${IN_PATH}/lib/${EXECUTABLE_TYPE}/libmodeller.so.1 \
+ ${IN_PATH}/lib/${EXECUTABLE_TYPE}/libmodeller.so
+
+ insinto ${IN_PATH}/modlib/
+ doins -r modeller-${VER}/modlib/{*mat,*lib,*prob,*mdt,*bin,*de,*inp,*ini,modeller}
+
+ insinto ${IN_PATH}/
+ doins -r modeller-${VER}/src
+
+ insinto /usr/share/${PN}/
+ doins -r modeller-${VER}/examples
+ dohtml modeller-${VER}/doc/*
+ dodoc modeller-${VER}/{README,ChangeLog}
+
+ cat >> "${T}/config.py" <<- EOF
+ install_dir = "${IN_PATH}/"
+ license = "YOURLICENSEKEY"
+ EOF
+
+ insinto ${IN_PATH}/modlib/modeller/
+ doins "${T}/config.py"
+}
+
+pkg_postinst(){
+ #Adapted from BUG #127628
+ einfo ""
+ einfo " If you need to define your own residues"
+ einfo " read the FAQ and edit the following files:"
+ einfo ""
+ einfo " ${MY_D}/modlib/top_heav.lib"
+ einfo " ${MY_D}/modlib/radii.lib"
+ einfo " ${MY_D}/modlib/radii14.lib"
+ einfo " ${MY_D}/modlib/restyp.lib"
+ einfo ""
+ einfo " Good Luck and Happy Modeling :D"
+ einfo ""
+ echo
+ echo
+ ewarn "Obtain a license Key from"
+ ewarn "http://salilab.org/modeller/registration.html"
+ ewarn "and change the appropriate line in"
+ ewarn "${IN_PATH}/modlib/modeller/config.py"
+}