aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorje_fro <je_fro@32389bae-6d03-0410-99cf-db05cde120eb>2008-04-09 16:14:50 +0000
committerje_fro <je_fro@32389bae-6d03-0410-99cf-db05cde120eb>2008-04-09 16:14:50 +0000
commite67ff56ac33c8e2fbb610e7ae1b90ffa5eae1dae (patch)
tree042668dc33f300099e48b6fcc4e75b54c1e83d3f /sci-chemistry/modeller
parentreadded geant (diff)
downloadsci-e67ff56ac33c8e2fbb610e7ae1b90ffa5eae1dae.tar.gz
sci-e67ff56ac33c8e2fbb610e7ae1b90ffa5eae1dae.tar.bz2
sci-e67ff56ac33c8e2fbb610e7ae1b90ffa5eae1dae.zip
Initial import, added MY_PV, thanks to the prolific Justin Schmitz
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1008 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-chemistry/modeller')
-rw-r--r--sci-chemistry/modeller/ChangeLog7
-rw-r--r--sci-chemistry/modeller/Manifest3
-rw-r--r--sci-chemistry/modeller/modeller-9.3.ebuild102
3 files changed, 112 insertions, 0 deletions
diff --git a/sci-chemistry/modeller/ChangeLog b/sci-chemistry/modeller/ChangeLog
new file mode 100644
index 000000000..5a7c8dafb
--- /dev/null
+++ b/sci-chemistry/modeller/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for sci-chemistry/modeller
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 09 Apr 2008; Jeff Gardner <je_fro@gentoo.org> +modeller-9.3.ebuild:
+ Initial import, added MY_PV, thanks to the prolific Justin Schmitz
+
diff --git a/sci-chemistry/modeller/Manifest b/sci-chemistry/modeller/Manifest
new file mode 100644
index 000000000..4f839ceaf
--- /dev/null
+++ b/sci-chemistry/modeller/Manifest
@@ -0,0 +1,3 @@
+DIST modeller-9v3.tar.gz 49912561 RMD160 9472bc951faa8e4a28b0834c58aa0d7100492412 SHA1 5f7589536923a9504ad52430fabf8dfc49dde3b1 SHA256 b70052c1fae18f4cba598ce15d3cfd46c2c0df10d23e066a65aceea59063f3ae
+EBUILD modeller-9.3.ebuild 3086 RMD160 201f380db839bbd229d0941e04770f4bcd928ac7 SHA1 7b4e6d2a0449b9cb73a63b477e4ca1278bef3739 SHA256 85a816203aaff7fcadf45667ec14ccc892fa1530e9492301361a0ae65a1628af
+MISC ChangeLog 263 RMD160 563b72a4b3bf2f08acfd672727d9ca54ebb538f0 SHA1 e5d554dd972d212918f43ef6fbb9f62123652b1b SHA256 1a0e0794deac9a2d648d90008bedea3288c2c25b904dd1a391a51655b5f68159
diff --git a/sci-chemistry/modeller/modeller-9.3.ebuild b/sci-chemistry/modeller/modeller-9.3.ebuild
new file mode 100644
index 000000000..795d8f8b2
--- /dev/null
+++ b/sci-chemistry/modeller/modeller-9.3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils python
+
+MY_PV="${PV/./v}"
+LICENSE="MODELLER"
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="MODELLER is used for homology or comparative modeling of protein three-dimensional structures"
+SRC_URI="http://salilab.org/${PN}/${MY_PV}/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://salilab.org/${PN}/"
+IUSE=""
+RESTRICT="mirror"
+SLOT="0"
+
+RDEPEND=">=dev-lang/python-2.4"
+DEPEND=""
+
+src_install(){
+ python_version
+
+ VER=9v3
+ case ${ARCH} in
+ x86) EXECUTABLE_TYPE="i386-intel8";;
+ amd64) EXECUTABLE_TYPE="x86_64-intel8";;
+ *) ewarn "Your arch "${ARCH}" does not appear supported at this time."||\
+ die "Unsupported Arch";;
+ esac
+
+ IN_PATH=/opt/modeller${VER}
+
+ sed -e "s:EXECUTABLE_TYPE${VER}=xxx:EXECUTABLE_TYPE${VER}=${EXECUTABLE_TYPE}:g" \
+ -e "s:MODINSTALL${VER}=xxx:MODINSTALL${VER}=\"${IN_PATH}\":g" \
+ modeller-${VER}/bin/modscript > "${T}/mod${VER}"
+ exeinto ${IN_PATH}/bin/
+ doexe "${T}/mod${VER}"
+ dosym ${IN_PATH}/bin/mod${VER} /opt/bin/mod${VER}
+
+ sed -e "s;@TOPDIR\@;\"${IN_PATH}\";" \
+ -e "s;@EXETYPE\@;$EXECUTABLE_TYPE;" \
+ modeller-${VER}/bin/modpy.sh.in > "${T}/modpy.sh"
+ doexe "${T}/modpy.sh"
+
+ insinto ${IN_PATH}/bin/
+ doins -r modeller-${VER}/bin/{*top,lib}
+ exeinto ${IN_PATH}/bin/
+ doexe modeller-${VER}/bin/{modslave.py,mod${VER}_${EXECUTABLE_TYPE}}
+
+ exeinto /usr/lib/python${PYVER}/site-packages/
+ doexe modeller-${VER}/lib/${EXECUTABLE_TYPE}/_modeller.so
+ dosym ${IN_PATH}/modlib/modeller /usr/lib/python${PYVER}/site-packages/modeller
+ dosym ${IN_PATH}/lib/${EXECUTABLE_TYPE}/_modeller.so\
+ /usr/lib/python${PYVER}/site-packages/_modeller.so
+
+ exeinto ${IN_PATH}/lib/${EXECUTABLE_TYPE}/
+ doexe modeller-${VER}/lib/${EXECUTABLE_TYPE}/{lib*,_modeller.so}
+ exeinto ${IN_PATH}/lib/${EXECUTABLE_TYPE}/python${PYVER}/
+ doexe modeller-${VER}/lib/${EXECUTABLE_TYPE}/python2.5/_modeller.so
+ dosym ${IN_PATH}/lib/${EXECUTABLE_TYPE}/libmodeller.so.1 \
+ ${IN_PATH}/lib/${EXECUTABLE_TYPE}/libmodeller.so
+
+ insinto ${IN_PATH}/modlib/
+ doins -r modeller-${VER}/modlib/{*mat,*lib,*prob,*mdt,*bin,*de,*inp,*ini,modeller}
+
+ insinto ${IN_PATH}/
+ doins -r modeller-${VER}/src
+
+ insinto /usr/share/${PN}/
+ doins -r modeller-${VER}/examples
+ dohtml modeller-${VER}/doc/*
+ dodoc modeller-${VER}/{README,ChangeLog}
+
+ cat >> "${T}/config.py" <<- EOF
+ install_dir = "${IN_PATH}/"
+ license = "YOURLICENSEKEY"
+ EOF
+
+ insinto ${IN_PATH}/modlib/modeller/
+ doins "${T}/config.py"
+}
+
+pkg_postinst(){
+ #Adapted from BUG #127628
+ einfo ""
+ einfo " If you need to define your own residues"
+ einfo " read the FAQ and edit the following files:"
+ einfo ""
+ einfo " ${MY_D}/modlib/top_heav.lib"
+ einfo " ${MY_D}/modlib/radii.lib"
+ einfo " ${MY_D}/modlib/radii14.lib"
+ einfo " ${MY_D}/modlib/restyp.lib"
+ einfo ""
+ einfo " Good Luck and Happy Modeling :D"
+ einfo ""
+ echo
+ echo
+ ewarn "Obtain a license Key from"
+ ewarn "http://salilab.org/modeller/registration.html"
+ ewarn "and change the appropriate line in"
+ ewarn "${IN_PATH}/modlib/modeller/config.py"
+}