aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-15 08:44:23 +0100
committerJustin Lecher <jlec@gentoo.org>2014-01-15 08:44:23 +0100
commitb176722593ec57ae62664e3a37a7d8d479a30da4 (patch)
treef335e16346f6dda12987d20d337121b0a56e6d28 /sci-chemistry/pymol
parentsci-libs/lemon: Import latest tree changes (diff)
downloadsci-b176722593ec57ae62664e3a37a7d8d479a30da4.tar.gz
sci-b176722593ec57ae62664e3a37a7d8d479a30da4.tar.bz2
sci-b176722593ec57ae62664e3a37a7d8d479a30da4.zip
sci-chemistry/pymol: Merge tree changes
Package-Manager: portage-2.2.8
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/ChangeLog5
-rw-r--r--sci-chemistry/pymol/Manifest2
-rw-r--r--sci-chemistry/pymol/pymol-9999.ebuild14
3 files changed, 12 insertions, 9 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index 795df1197..54449711f 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-chemistry/pymol
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 15 Jan 2014; Justin Lecher <jlec@gentoo.org> pymol-9999.ebuild:
+ Merge tree changes
+
24 Jul 2013; Justin Lecher <jlec@gentoo.org> pymol-9999.ebuild:
Fx stupid argparse import
diff --git a/sci-chemistry/pymol/Manifest b/sci-chemistry/pymol/Manifest
index 4aec698a3..6dd1dc11d 100644
--- a/sci-chemistry/pymol/Manifest
+++ b/sci-chemistry/pymol/Manifest
@@ -1 +1 @@
-DIST pymol-icons.tar.xz 38100 SHA256 03500f28256f67abfbb7d08b798b11aaa208f0ae1473ef2a7205b3c012ddb06a SHA512 5af51014d4fcbc85ef1fecd7667224709c9305b9b72bfdfd89ece2b4420fa8a81bf8c85fcc5903e2a670f44403f12764808f6a16ef42f111bbd0e7ed8e412d54 WHIRLPOOL 6104d378928c56b39f8cbe29184629b73f87da09e81e41ddc08b9b291876f1a30ccaf9ec257f47798c6d03253816f80c14567073c419fa48dd1520fa3fa58ecd
+DIST pymol-1.7.0.0.png.xz 5392 SHA256 4c554a5c4f47946b6f7bae00209d5116305162534292735d30ae0794c56a8a0b SHA512 24bb1584b28688f5d5824e938f8500ca9887838adf490b4284c52f8c0da4c5ec4a56051ee80f48e4f34541ab53f9a4e00c849c382f1fd37c232fbea12d700105 WHIRLPOOL 395f978eb9ea3a8f8f39bf0694f71986ac9f8ebb307b90283c53fed85c4412d84e54af472f8646fcbd99c650039cb395a8f02b281168802c73ddb9bad175512b
diff --git a/sci-chemistry/pymol/pymol-9999.ebuild b/sci-chemistry/pymol/pymol-9999.ebuild
index 4d5a6bdac..b610295e2 100644
--- a/sci-chemistry/pymol/pymol-9999.ebuild
+++ b/sci-chemistry/pymol/pymol-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -11,7 +11,7 @@ inherit distutils-r1 fdo-mime subversion versionator
DESCRIPTION="A Python-extensible molecular graphics system"
HOMEPAGE="http://pymol.sourceforge.net/"
-SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${PN}-icons.tar.xz"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${PN}-1.7.0.0.png.xz"
ESVN_REPO_URI="svn://svn.code.sf.net/p/pymol/code/trunk/pymol"
LICENSE="PSF-2.2"
@@ -22,6 +22,7 @@ IUSE="apbs web"
DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pmw[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
media-libs/freetype:2
media-libs/glew
media-libs/libpng
@@ -32,9 +33,9 @@ DEPEND="
dev-libs/maloc
sci-chemistry/apbs
sci-chemistry/pdb2pqr
- sci-chemistry/pymol-apbs-plugin
+ sci-chemistry/pymol-apbs-plugin[${PYTHON_USEDEP}]
)
- web? ( !dev-python/webpy )"
+ web? ( !dev-python/webpy[${PYTHON_USEDEP}] )"
RDEPEND="${DEPEND}"
src_unpack() {
@@ -46,7 +47,6 @@ python_prepare_all() {
sed \
-e "s:\"/usr:\"${EPREFIX}/usr:g" \
-e "/ext_comp_args/s:=\[.*\]$:= \[\]:g" \
- -e "/import/s:argparse:argparseX:g" \
-i setup.py || die
rm ./modules/pmg_tk/startup/apbs_tools.py || die
@@ -83,11 +83,11 @@ python_install_all() {
doenvd "${T}"/20pymol
- doicon "${WORKDIR}"/${PN}.{xpm,png}
+ newicon "${WORKDIR}"/${P}.png ${PN}.png
make_desktop_entry pymol PyMol ${PN} "Graphics;Education;Science;Chemistry" "MimeType=chemical/x-pdb;"
if ! use web; then
- rm -rvf "${D}/$(python_get_sitedir)/web" || die
+ rm -rf "${D}/$(python_get_sitedir)/web" || die
fi
rm -f "${ED}"/usr/share/${PN}/LICENSE || die