aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-09-23 23:18:48 -0600
committerChristoph Junghans <ottxor@gentoo.org>2015-09-23 23:21:14 -0600
commit239fa34edcca3183dc35551fe199077be52f59cc (patch)
tree468ae42610ee3231857c7faa7a573553724ed03b /sci-chemistry/votca-csg
parentsci-libs/votca-tools: sync with gx86 (diff)
downloadsci-239fa34edcca3183dc35551fe199077be52f59cc.tar.gz
sci-239fa34edcca3183dc35551fe199077be52f59cc.tar.bz2
sci-239fa34edcca3183dc35551fe199077be52f59cc.zip
sci-chemistry/votca-csg: sync with gx86
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-chemistry/votca-csg')
-rw-r--r--sci-chemistry/votca-csg/ChangeLog3
-rw-r--r--sci-chemistry/votca-csg/votca-csg-9999.ebuild39
2 files changed, 25 insertions, 17 deletions
diff --git a/sci-chemistry/votca-csg/ChangeLog b/sci-chemistry/votca-csg/ChangeLog
index 1c1eb1dca..827dd5d87 100644
--- a/sci-chemistry/votca-csg/ChangeLog
+++ b/sci-chemistry/votca-csg/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 24 Sep 2015; Christoph Junghans <ottxor@gentoo.org> votca-csg-9999.ebuild:
+ sci-chemistry/votca-csg: sync with gx86
+
12 Feb 2015; Christoph Junghans <ottxor@gentoo.org> votca-csg-9999.ebuild:
added support of hdf5, clean up
diff --git a/sci-chemistry/votca-csg/votca-csg-9999.ebuild b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
index 7f7a214ac..668702c9c 100644
--- a/sci-chemistry/votca-csg/votca-csg-9999.ebuild
+++ b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
@@ -11,14 +11,14 @@ inherit bash-completion-r1 cmake-utils multilib
IUSE="doc examples extras +gromacs hdf5"
PDEPEND="extras? ( =sci-chemistry/${PN}apps-${PV} )"
if [ "${PV}" != "9999" ]; then
- SRC_URI="http://downloads.votca.googlecode.com/hg/${P}.tar.gz
- doc? ( http://downloads.votca.googlecode.com/hg/${PN}-manual-${PV}.pdf )
- examples? ( http://downloads.votca.googlecode.com/hg/${PN}-tutorials-${PV}.tar.gz )"
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://github.com/${PN/-//}-manual/releases/download/v1.3_rc1/${PN}-manual-${PV}.pdf )
+ examples? ( https://github.com/${PN/-//}-tutorials/archive/v${PV}.tar.gz -> ${PN}-tutorials-${PV}.tar.gz )"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
else
- SRC_URI=""
- inherit mercurial
- EHG_REPO_URI="https://code.google.com/p/votca.csg/"
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git https://github.com/${PN/-//}.git"
KEYWORDS=""
fi
@@ -45,21 +45,25 @@ DEPEND="${RDEPEND}
>=app-text/txt2tags-2.5
virtual/pkgconfig"
-DOCS=( README NOTICE )
+DOCS=( README.md NOTICE CHANGELOG.md )
src_unpack() {
if [[ ${PV} != *9999 ]]; then
default
else
- mercurial_src_unpack
- use doc && mercurial_fetch \
- https://code.google.com/p/votca.csg-manual/ \
- votca.csg-manual \
- "${WORKDIR}/${PN}-manual"
- use examples && mercurial_fetch \
- https://code.google.com/p/votca.csg-tutorials/ \
- votca.csg-tutorials \
- "${WORKDIR}/${PN}-tutorials"
+ git-r3_src_unpack
+ if use doc; then
+ EGIT_REPO_URI="git://github.com/${PN/-//}-manual.git https://github.com/${PN/-//}-manual.git"
+ EGIT_BRANCH="master"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}-manual"\
+ git-r3_src_unpack
+ fi
+ if use examples; then
+ EGIT_REPO_URI="git://github.com/${PN/-//}-tutorials.git https://github.com/${PN/-//}-tutorials.git"
+ EGIT_BRANCH="master"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PN#votca-}-tutorials"\
+ git-r3_src_unpack
+ fi
fi
}
@@ -96,7 +100,8 @@ src_install() {
if use examples; then
insinto "/usr/share/doc/${PF}/tutorials"
docompress -x "/usr/share/doc/${PF}/tutorials"
- doins -r "${WORKDIR}/${PN}"-tutorials*/*
+ rm -rf "${WORKDIR}/${PN#votca-}"-tutorials*/CMake*
+ doins -r "${WORKDIR}/${PN#votca-}"-tutorials*/*
fi
}