aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-02-15 23:23:01 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2009-02-15 23:23:01 +0300
commitf6a1648c61965d0689ebb54efe82004f13b14043 (patch)
treeb5cb26307edc98e063c7fb1dc367a5085b6239d4 /sci-chemistry/wxmacmolplt/wxmacmolplt-7.2.1.ebuild
parentsci-chemistry/almost missed to install to headers which are needed to build s... (diff)
downloadsci-f6a1648c61965d0689ebb54efe82004f13b14043.tar.gz
sci-f6a1648c61965d0689ebb54efe82004f13b14043.tar.bz2
sci-f6a1648c61965d0689ebb54efe82004f13b14043.zip
fix compilation of wxmacmolplt
(Portage version: 2.2_rc23/git/Linux x86_64) (Signed Manifest commit)
Diffstat (limited to 'sci-chemistry/wxmacmolplt/wxmacmolplt-7.2.1.ebuild')
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.2.1.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.2.1.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.2.1.ebuild
index 78e09e16a..e62e71ca8 100644
--- a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.2.1.ebuild
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.2.1.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
+EAPI="2"
+
+inherit base eutils
DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
HOMEPAGE="http://www.scl.ameslab.gov/~brett/MacMolPlt/"
@@ -20,20 +22,16 @@ RDEPEND="x11-libs/wxGTK
DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-ming.patch"
- epatch "${FILESDIR}/${P}-gcc43.patch"
-}
+PATCHES=( "${FILESDIR}"/${P}-ming.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ )
-src_compile() {
- econf $(use_with ming) || die "configure failed"
- emake || die "make failed"
+src_configure() {
+ LIBS="-lGLU" econf $(use_with ming)
}
src_install() {
emake DESTDIR="${D}" install || die "install failed"
doicon resources/${PN}.png
- make_desktop_entry ${PN} wxMacMolPlt ${PN}.png Education
+ make_desktop_entry ${PN} wxMacMolPlt ${PN}.png Science
}