aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-28 22:03:58 +0100
committerJustin Lecher <jlec@gentoo.org>2012-10-28 22:03:58 +0100
commit5ba6526e789af2d14754a47f24c7e336cc420e12 (patch)
tree5f481af75b4dd40c00b1c11f3af7d911eb6df57e /sci-chemistry/wxmacmolplt
parentsci-physics/root, app-doc/root-doc: update Manifest (diff)
downloadsci-5ba6526e789af2d14754a47f24c7e336cc420e12.tar.gz
sci-5ba6526e789af2d14754a47f24c7e336cc420e12.tar.bz2
sci-5ba6526e789af2d14754a47f24c7e336cc420e12.zip
sci-chemistry/wxmacmolplt: Fix prefix awareness; correct desktop file creation
Package-Manager: portage-2.2.0_alpha142
Diffstat (limited to 'sci-chemistry/wxmacmolplt')
-rw-r--r--sci-chemistry/wxmacmolplt/ChangeLog4
-rw-r--r--sci-chemistry/wxmacmolplt/metadata.xml10
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.3.ebuild10
3 files changed, 14 insertions, 10 deletions
diff --git a/sci-chemistry/wxmacmolplt/ChangeLog b/sci-chemistry/wxmacmolplt/ChangeLog
index c858c58fc..916fc27f5 100644
--- a/sci-chemistry/wxmacmolplt/ChangeLog
+++ b/sci-chemistry/wxmacmolplt/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 28 Oct 2012; Justin Lecher <jlec@gentoo.org> wxmacmolplt-7.4.3.ebuild,
+ metadata.xml:
+ Fix prefix awareness; correct desktop file creation
+
*wxmacmolplt-7.4.3 (22 Oct 2012)
22 Oct 2012; Reinis Danne <rei4dan@gmail.com> +wxmacmolplt-7.4.3.ebuild,
diff --git a/sci-chemistry/wxmacmolplt/metadata.xml b/sci-chemistry/wxmacmolplt/metadata.xml
index fb69a7dab..37abac1f9 100644
--- a/sci-chemistry/wxmacmolplt/metadata.xml
+++ b/sci-chemistry/wxmacmolplt/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<longdescription>
+ <herd>sci-chemistry</herd>
+ <longdescription>
wxMacMolPlt is a program for plotting 3D molecular structures and normal modes (vibrations), various orbitals and electron density maps. It reads a variety of file formats including any GAMESS input, log or IRC file directly to create animations. It has a simple GAMESS input (.inp) builder and a primitive molecule builder.
</longdescription>
-<use>
- <flag name='flash'>Add support for flash movie generation using <pkg>media-libs/ming</pkg></flag>
-</use>
+ <use>
+ <flag name="flash">Add support for flash movie generation using <pkg>media-libs/ming</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.3.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.3.ebuild
index 8b300c9cf..233dac13c 100644
--- a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.3.ebuild
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="5"
+EAPI=5
WX_GTK_VER=2.8
inherit base eutils autotools wxwidgets
@@ -17,7 +17,7 @@ SLOT="0"
IUSE="flash"
RDEPEND="
- >=media-libs/glew-1.5.3
+ media-libs/glew
media-libs/mesa
x11-libs/wxGTK:2.8[X,opengl]
flash? ( media-libs/ming )"
@@ -38,7 +38,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${ED}" install || die "install failed"
- doicon resources/${PN}.png || die
- make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;Education"
+ default
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
}