aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-27 20:13:23 +0200
committerJustin Lecher <jlec@gentoo.org>2010-06-27 23:10:03 +0200
commit12e33c6865635a65068b35b4d325e7fc58f1d973 (patch)
treedf29fdb4fe9456274498152515b6bab75b6b6dc9 /sci-chemistry
parentPython ABI fixes (diff)
downloadsci-12e33c6865635a65068b35b4d325e7fc58f1d973.tar.gz
sci-12e33c6865635a65068b35b4d325e7fc58f1d973.tar.bz2
sci-12e33c6865635a65068b35b4d325e7fc58f1d973.zip
Python ABI fixes
(Portage version: 2.2_rc67/git/Linux x86_64) (Signed Manifest commit)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mgltools-bhtree/ChangeLog8
-rw-r--r--sci-chemistry/mgltools-bhtree/Manifest14
-rw-r--r--sci-chemistry/mgltools-bhtree/mgltools-bhtree-1.5.4-r1.ebuild (renamed from sci-chemistry/mgltools-bhtree/mgltools-bhtree-1.5.4.ebuild)20
3 files changed, 38 insertions, 4 deletions
diff --git a/sci-chemistry/mgltools-bhtree/ChangeLog b/sci-chemistry/mgltools-bhtree/ChangeLog
index 58010f61e..64bfbbbc7 100644
--- a/sci-chemistry/mgltools-bhtree/ChangeLog
+++ b/sci-chemistry/mgltools-bhtree/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sci-chemistry/mgltools-bhtree
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*mgltools-bhtree-1.5.4-r1 (27 Jun 2010)
+
+ 27 Jun 2010; Justin Lecher <jlec@gentoo.org>
+ -mgltools-bhtree-1.5.4.ebuild, +mgltools-bhtree-1.5.4-r1.ebuild:
+ Python ABI fixes
+
*mgltools-bhtree-1.5.4 (17 May 2009)
17 May 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
diff --git a/sci-chemistry/mgltools-bhtree/Manifest b/sci-chemistry/mgltools-bhtree/Manifest
index 5facbcfeb..8e5630654 100644
--- a/sci-chemistry/mgltools-bhtree/Manifest
+++ b/sci-chemistry/mgltools-bhtree/Manifest
@@ -1,4 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
DIST mgltools_source_1.5.4.tar.gz 21591865 RMD160 faa158477c4e9156ee5fd23b89251e5bedbd689d SHA1 3b3056a75cd944a4aa46771e09916a4e85052b88 SHA256 d0c614e167512bd19127c741cb2d9860443c097f7ccf0bbe244c0b155e59a9c2
-EBUILD mgltools-bhtree-1.5.4.ebuild 946 RMD160 48641202ae525e0c3eb398c4b1000ae91e095aa0 SHA1 65cd7c03b855e2480b3910138a33281cb524b5ab SHA256 3fdfdd28e67f86b7911a2a4ebb83a2eb3271e7a8db8494b275a2fb9798a5807f
-MISC ChangeLog 292 RMD160 cb48cde93d1d7c2d274b5ed4d31da91ea5eac7a2 SHA1 652ef92037b48040d0b7e2e2f6715ddd3bd0c3b3 SHA256 fa228308b4b26c61a4a7435286ad2d623a3062500f51b469c06857ded9a91516
+EBUILD mgltools-bhtree-1.5.4-r1.ebuild 1161 RMD160 441374cb0010a972b1499818d4e2ab9487fd5c32 SHA1 dcd7fe0c3d81a3559491aca46234e78ecae17d80 SHA256 09a4a5980feddfc65c88822d5815201d3f16be9c2fc789d0f7034ba05dea26f4
+MISC ChangeLog 467 RMD160 a919dbb3b65515c7febe000baa1eb934ac26bddf SHA1 a6a803b95c5187fa696033a0c485b4bfc2780a86 SHA256 00c99def1a7170985b37d27954f47d68faec22b15d872e5df7d9a2a644398cfb
MISC metadata.xml 215 RMD160 bc9c07aa91f2f175542244e4e4522a73558210a1 SHA1 facb283386de1c0b6b938cdcd4dde04d1694298b SHA256 13f32353652adbd3d934d41381cfc2cacc9e1127c508cebc73806cc1026ee80c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkwnlMMACgkQgAnW8HDreRbQvACgzh95V9uxAyv8CQp166g28gEP
+FK4An2yigU9QyobwL1rTkOZb4treW4n8
+=VkRm
+-----END PGP SIGNATURE-----
diff --git a/sci-chemistry/mgltools-bhtree/mgltools-bhtree-1.5.4.ebuild b/sci-chemistry/mgltools-bhtree/mgltools-bhtree-1.5.4-r1.ebuild
index c264e5aa4..93ed80744 100644
--- a/sci-chemistry/mgltools-bhtree/mgltools-bhtree-1.5.4.ebuild
+++ b/sci-chemistry/mgltools-bhtree/mgltools-bhtree-1.5.4-r1.ebuild
@@ -1,7 +1,12 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
inherit distutils
MY_P="${P/mgltools-}"
@@ -20,12 +25,16 @@ RDEPEND="dev-python/numpy"
DEPEND="${RDEPEND}
dev-lang/swig"
+RESTRICT_PYTHON_ABIS="3.*"
+
S="${WORKDIR}"/${MY_P}
src_unpack() {
tar xzpf "${DISTDIR}"/${A} mgltools_source_${PV}/MGLPACKS/${MY_P}.tar.gz
tar xzpf mgltools_source_${PV}/MGLPACKS/${MY_P}.tar.gz
+}
+src_prepare() {
find "${S}" -name CVS -type d -exec rm -rf '{}' \; >& /dev/null
find "${S}" -name LICENSE -type f -exec rm -f '{}' \; >& /dev/null
@@ -33,4 +42,13 @@ src_unpack() {
-e 's:^.*CVS:#&1:g' \
-e 's:^.*LICENSE:#&1:g' \
-i "${S}"/MANIFEST.in
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+ python_mod_optimize bhtree
+}
+
+pkg_postrm() {
+ python_mod_cleanup bhtree
}