aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-07-10 17:59:33 +0200
committerJustin Lecher <jlec@gentoo.org>2013-07-10 17:59:33 +0200
commit46d59e4fbb34740a30b263e90e5d27ae01fd4eb9 (patch)
tree95b5d2111343f5a5cf326ac2465b5d9bf2434ed5 /sci-chemistry
parentMerge branch 'master' of git://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-46d59e4fbb34740a30b263e90e5d27ae01fd4eb9.tar.gz
sci-46d59e4fbb34740a30b263e90e5d27ae01fd4eb9.tar.bz2
sci-46d59e4fbb34740a30b263e90e5d27ae01fd4eb9.zip
sci-chemistry/gnome-chemistry-utils: Add live ebuild, fix extern C problems, #474498 and https://github.com/gentoo-science/sci/issues/84
Package-Manager: portage-2.2.0_alpha188
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gnome-chemistry-utils/ChangeLog8
-rw-r--r--sci-chemistry/gnome-chemistry-utils/files/gnome-chemistry-utils-0.14.2-extern-c.patch84
-rw-r--r--sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.2.ebuild12
-rw-r--r--sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-9999.ebuild53
4 files changed, 155 insertions, 2 deletions
diff --git a/sci-chemistry/gnome-chemistry-utils/ChangeLog b/sci-chemistry/gnome-chemistry-utils/ChangeLog
index f45e5bf6a..d08eb8260 100644
--- a/sci-chemistry/gnome-chemistry-utils/ChangeLog
+++ b/sci-chemistry/gnome-chemistry-utils/ChangeLog
@@ -2,6 +2,14 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*gnome-chemistry-utils-9999 (10 Jul 2013)
+
+ 10 Jul 2013; Justin Lecher <jlec@gentoo.org>
+ gnome-chemistry-utils-0.14.2.ebuild, +gnome-chemistry-utils-9999.ebuild,
+ +files/gnome-chemistry-utils-0.14.2-extern-c.patch:
+ Add live ebuild, fix extern C problems, #474498 and
+ https://github.com/gentoo-science/sci/issues/84
+
21 Jun 2013; Justin Lecher <jlec@gentoo.org>
gnome-chemistry-utils-0.14.2.ebuild, metadata.xml:
Fix min version of openbabel
diff --git a/sci-chemistry/gnome-chemistry-utils/files/gnome-chemistry-utils-0.14.2-extern-c.patch b/sci-chemistry/gnome-chemistry-utils/files/gnome-chemistry-utils-0.14.2-extern-c.patch
new file mode 100644
index 000000000..f505af970
--- /dev/null
+++ b/sci-chemistry/gnome-chemistry-utils/files/gnome-chemistry-utils-0.14.2-extern-c.patch
@@ -0,0 +1,84 @@
+ goffice/gchemutils-priv.h | 2 +-
+ goffice/gchemutils.cc | 7 ++++---
+ goffice/gchemutils.h | 6 +++---
+ goffice/gogcuapp.h | 2 +-
+ 4 files changed, 9 insertions(+), 8 deletions(-)
+
+diff --git a/goffice/gchemutils-priv.h b/goffice/gchemutils-priv.h
+index 480e1a5..deb9687 100644
+--- a/goffice/gchemutils-priv.h
++++ b/goffice/gchemutils-priv.h
+@@ -23,12 +23,12 @@
+ #ifndef GOFFICE_GCHEMUTILS_PRIV_H
+ #define GOFFICE_GCHEMUTILS_PRIV_H
+
+-#include "gchemutils.h"
+ #include <gcu/chem3ddoc.h>
+ #include <gcu/structs.h>
+ #include <gogcuapp.h>
+ #include <gcu/document.h>
+ #include <gcugtk/window.h>
++#include "gchemutils.h"
+
+ struct _GOGChemUtilsComponent
+ {
+diff --git a/goffice/gchemutils.cc b/goffice/gchemutils.cc
+index 2aa85b5..a477b13 100644
+--- a/goffice/gchemutils.cc
++++ b/goffice/gchemutils.cc
+@@ -20,6 +20,10 @@
+ * USA
+ */
+
++#include <map>
++#include <string>
++#include <cstring>
++
+ #include "config.h"
+ #include "gchemutils-priv.h"
+ #include "gogcpapp.h"
+@@ -31,9 +35,6 @@
+ #include <goffice/app/module-plugin-defs.h>
+ #include <goffice/component/go-component-factory.h>
+ #include <glib/gi18n-lib.h>
+-#include <map>
+-#include <string>
+-#include <cstring>
+
+ //gcuGOfficeApplication *app;
+
+diff --git a/goffice/gchemutils.h b/goffice/gchemutils.h
+index 2f62aa5..8e6acb9 100644
+--- a/goffice/gchemutils.h
++++ b/goffice/gchemutils.h
+@@ -23,12 +23,12 @@
+ #ifndef GOFFICE_GCHEMPAINT_H
+ #define GOFFICE_GCHEMPAINT_H
+
+-#include <goffice/component/goffice-component.h>
+-#include <goffice/component/go-component.h>
+-
+ extern "C"
+ {
+
++#include <goffice/component/goffice-component.h>
++#include <goffice/component/go-component.h>
++
+ typedef struct _GOGChemUtilsComponent GOGChemUtilsComponent;
+
+ typedef GOComponentClass GOGChemUtilsComponentClass;
+diff --git a/goffice/gogcuapp.h b/goffice/gogcuapp.h
+index 0012931..0cad715 100644
+--- a/goffice/gogcuapp.h
++++ b/goffice/gogcuapp.h
+@@ -23,9 +23,9 @@
+ #ifndef GO_GCU_APP_H
+ #define GO_GCU_APP_H
+
+-#include "gchemutils.h"
+ #include <gcu/structs.h>
+ #include <string>
++#include "gchemutils.h"
+
+ namespace gcu {
+ class Document;
diff --git a/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.2.ebuild b/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.2.ebuild
index e0d8c6a23..a76125264 100644
--- a/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.2.ebuild
+++ b/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.2.ebuild
@@ -5,12 +5,11 @@
EAPI="5"
GCONF_DEBUG="no"
-inherit gnome2 versionator
+inherit eutils gnome2 versionator
DESCRIPTION="Programs and library containing GTK widgets and C++ classes related to chemistry"
HOMEPAGE="http://gchemutils.nongnu.org/"
SRC_URI="http://download.savannah.gnu.org/releases/gchemutils/$(get_version_component_range 1-2)/${P}.tar.bz2"
-RESTRICT="mirror"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -34,6 +33,15 @@ DEPEND="
virtual/pkgconfig
app-doc/doxygen"
+RESTRICT="mirror"
+
+PATCHES=( "${FILESDIR}"/${P}-extern-c.patch )
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+ gnome2_src_prepare
+}
+
src_configure() {
local myeconfargs=(
$(use_enable nls)
diff --git a/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-9999.ebuild b/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-9999.ebuild
new file mode 100644
index 000000000..b6a74ef58
--- /dev/null
+++ b/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+inherit autotools flag-o-matic gnome2 versionator subversion
+
+DESCRIPTION="Programs and library containing GTK widgets and C++ classes related to chemistry"
+HOMEPAGE="http://gchemutils.nongnu.org/"
+SRC_URI=""
+ESVN_REPO_URI="svn://svn.savannah.nongnu.org/gchemutils/trunk/gchemutils"
+
+SLOT="0"
+KEYWORDS=""
+LICENSE="GPL-3 FDL-1.3"
+IUSE="gnumeric nls"
+
+RDEPEND="
+ >=dev-libs/glib-2.36.0:2
+ >=dev-libs/libxml2-2.4.16:2
+ >=gnome-extra/libgsf-1.14.9
+ >=sci-chemistry/bodr-5
+ >=sci-chemistry/chemical-mime-data-0.1.94
+ >=sci-chemistry/openbabel-2.3.0
+ >=x11-libs/cairo-1.6.0
+ >=x11-libs/gdk-pixbuf-2.22.0
+ >=x11-libs/goffice-0.10.0
+ x11-libs/gtk+:3
+ >=x11-libs/libX11-1.0.0
+ gnumeric? ( >=app-office/gnumeric-1.11.6 )"
+DEPEND="
+ virtual/pkgconfig
+ app-doc/doxygen"
+
+RESTRICT="mirror"
+
+ESVN_BOOTSTRAP="eautoreconf"
+
+src_prepare() {
+ subversion_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ --disable-mozilla-plugin
+ --disable-update-databases
+ )
+ gnome2_src_configure ${myeconfargs[@]}
+}