aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-30 15:54:01 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-30 15:54:01 +0100
commit4b1645fe18182c7a4311be24baffc31ad0947f7d (patch)
tree49954a9d4b9e4e42fcc2c22aad520f809ea4cdb2 /sci-chemistry
parentsci-libs/lapacke-reference: Version Bump (diff)
downloadsci-4b1645fe18182c7a4311be24baffc31ad0947f7d.tar.gz
sci-4b1645fe18182c7a4311be24baffc31ad0947f7d.tar.bz2
sci-4b1645fe18182c7a4311be24baffc31ad0947f7d.zip
Update to new cmake-utils API
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild8
-rw-r--r--sci-chemistry/votca-csg/votca-csg-9999.ebuild4
2 files changed, 6 insertions, 6 deletions
diff --git a/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild b/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
index 0a0fee043..e61d4729d 100644
--- a/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
+++ b/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
@@ -46,18 +46,18 @@ src_compile() {
}
src_test() {
- mkdir "${CMAKE_BUILD_DIR}/$(get_libdir)/Chemistry"
+ mkdir "${BUILD_DIR}/$(get_libdir)/Chemistry"
cp \
"${CMAKE_USE_DIR}/scripts/perl/OpenBabel.pm" \
- "${CMAKE_BUILD_DIR}/$(get_libdir)/Chemistry/"
+ "${BUILD_DIR}/$(get_libdir)/Chemistry/"
for i in "${CMAKE_USE_DIR}"/scripts/perl/t/*
do
einfo "Running test: ${i}"
- perl -I"${CMAKE_BUILD_DIR}/$(get_libdir)" "${i}" || die
+ perl -I"${BUILD_DIR}/$(get_libdir)" "${i}" || die
done
}
src_install() {
- cd "${CMAKE_BUILD_DIR}"
+ cd "${BUILD_DIR}"
cmake -DCOMPONENT=bindings_perl -P cmake_install.cmake
}
diff --git a/sci-chemistry/votca-csg/votca-csg-9999.ebuild b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
index 0a099b440..25892d72d 100644
--- a/sci-chemistry/votca-csg/votca-csg-9999.ebuild
+++ b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
@@ -94,8 +94,8 @@ src_install() {
else
dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
fi
- cmake-utils_src_make -C "${CMAKE_BUILD_DIR}" html
- dohtml -r "${CMAKE_BUILD_DIR}"/share/doc/html/*
+ cmake-utils_src_make -C "${BUILD_DIR}" html
+ dohtml -r "${BUILD_DIR}"/share/doc/html/*
fi
if use examples; then
insinto "/usr/share/doc/${PF}/tutorials"