aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortulku <tulku@32389bae-6d03-0410-99cf-db05cde120eb>2005-10-24 01:58:16 +0000
committertulku <tulku@32389bae-6d03-0410-99cf-db05cde120eb>2005-10-24 01:58:16 +0000
commit1081f6332b47777b1b5d3cb8fbe184821ad7f8b7 (patch)
treece1957ec79da9917f435349aad8c40f08e0dc119 /sci-electronics/gsmc/gsmc-1.0.ebuild
parentCreated initial directory structure. (diff)
downloadsci-1081f6332b47777b1b5d3cb8fbe184821ad7f8b7.tar.gz
sci-1081f6332b47777b1b5d3cb8fbe184821ad7f8b7.tar.bz2
sci-1081f6332b47777b1b5d3cb8fbe184821ad7f8b7.zip
Adding new ebuild for gsmc-1.0
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@2 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-electronics/gsmc/gsmc-1.0.ebuild')
-rw-r--r--sci-electronics/gsmc/gsmc-1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-electronics/gsmc/gsmc-1.0.ebuild b/sci-electronics/gsmc/gsmc-1.0.ebuild
new file mode 100644
index 000000000..aab515c11
--- /dev/null
+++ b/sci-electronics/gsmc/gsmc-1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A GTK program for doing Smith Chart calculations"
+HOMEPAGE="http://www.qsl.net/ik5nax/"
+SRC_URI="http://www.qsl.net/ik5nax/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.0"
+RDEPEND=""
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} PREFIX=/usr/ install || die "make install failed"
+ dodoc AUTHORS NEWS README ChangeLog TODO
+}