aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortulku <tulku@32389bae-6d03-0410-99cf-db05cde120eb>2006-04-14 15:16:52 +0000
committertulku <tulku@32389bae-6d03-0410-99cf-db05cde120eb>2006-04-14 15:16:52 +0000
commitb78c8f0687b9294d4f2b38b774dd89fb6bfb73bf (patch)
tree00ce9240e7ed44134af72f9a6806a7cb9a14f0d2 /sci-electronics
parentmaxima-5.9.3: removed unicode patch (diff)
downloadsci-b78c8f0687b9294d4f2b38b774dd89fb6bfb73bf.tar.gz
sci-b78c8f0687b9294d4f2b38b774dd89fb6bfb73bf.tar.bz2
sci-b78c8f0687b9294d4f2b38b774dd89fb6bfb73bf.zip
Version bump
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@160 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/linsmith/ChangeLog5
-rw-r--r--sci-electronics/linsmith/Manifest5
-rw-r--r--sci-electronics/linsmith/linsmith-0.9.5.ebuild69
3 files changed, 77 insertions, 2 deletions
diff --git a/sci-electronics/linsmith/ChangeLog b/sci-electronics/linsmith/ChangeLog
index 21078f8db..fe37e9015 100644
--- a/sci-electronics/linsmith/ChangeLog
+++ b/sci-electronics/linsmith/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*linsmith-0.9.5 (14 Apr 2006)
+
+ 14 Apr 2006; Lucas Chiesa <lucas.chiesa@gmail.com> linsmith-0.9.5.ebuild:
+ Version bump.
+
*linsmith-0.9.4 (09 Apr 2006)
09 Apr 2006; Lucas Chiesa <lucas.chiesa@gmail.com> linsmith-0.9.4.ebuild:
diff --git a/sci-electronics/linsmith/Manifest b/sci-electronics/linsmith/Manifest
index 62e950210..a162b6f7c 100644
--- a/sci-electronics/linsmith/Manifest
+++ b/sci-electronics/linsmith/Manifest
@@ -1,10 +1,11 @@
-MD5 24c8cb5f563be0ec92a31f98262af3cf ChangeLog 1232
+MD5 5b7f9a895e55a4d86a4856edb595a737 ChangeLog 1345
MD5 5a703fe843b2106c41c9340f5e11d06c files/digest-linsmith-0.9.0_alpha3 69
MD5 95537ed9cba1bbe703d4b91d48818c04 files/digest-linsmith-0.9.1 67
MD5 e39a16484672a5341e46e92ce9aff8d1 files/digest-linsmith-0.9.2 66
MD5 a6df390c5a8f3a558a6a23aee446f7e5 files/digest-linsmith-0.9.4 67
+MD5 3514b4891ceefe51e3b5e1288d0bf29d files/digest-linsmith-0.9.5 67
MD5 8eed8f5e5acb161567180193e3c94642 files/linsmith-datafiles.patch 757
MD5 afadc040e05573a886c5152caf055233 files/linsmith.1 2109
-MD5 02dde9f622b65a66633500bbc515a1fc linsmith-0.9.2.ebuild 1503
MD5 73c962013d6b5c3c8c680eb6f5bc37e5 linsmith-0.9.4.ebuild 1499
+MD5 73c962013d6b5c3c8c680eb6f5bc37e5 linsmith-0.9.5.ebuild 1499
MD5 e86b876c1011b9eef88da979183746eb metadata.xml 260
diff --git a/sci-electronics/linsmith/linsmith-0.9.5.ebuild b/sci-electronics/linsmith/linsmith-0.9.5.ebuild
new file mode 100644
index 000000000..d4ccb5b7c
--- /dev/null
+++ b/sci-electronics/linsmith/linsmith-0.9.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="linSmith is a Smith Charting program, mainly designed for
+educational use."
+HOMEPAGE="http://jcoppens.com/soft/linsmith/index.en.php"
+
+SRC_URI="mirror://sourceforge/linsmith/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND=">=gnome-base/libgnomeprint-2.10.3
+ >=dev-libs/libxml2-2.6.20-r2
+ >=gnome-base/libgnomeui-2.10.1"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # This patch is to prevent make install copying
+ # the examples in /usr/share/linsmith
+ # Now they are cp to the correct location.
+ epatch ${FILESDIR}/${PN}-datafiles.patch
+
+ einfo "Regenerating autotools files..."
+ WANT_AUTOMAKE=1.8 automake || die "automake failed"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${S}
+
+ # Delete this file, otherwise it is installed with the pixmaps.
+ rm pixmaps/Makefile.am~
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ insinto "/usr/share/${PN}/"
+ doins datafiles/conv0809
+
+ dodoc AUTHORS NEWS README ChangeLog TODO
+ doman doc/linsmith.1
+
+ insinto "/usr/share/applications/"
+ doins linsmith.desktop
+ insinto "/usr/share/pixmaps/${PN}/"
+ doins linsmith_icon.xpm
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}/"
+ doins doc/manual.pdf
+ fi
+
+ insinto "/usr/share/doc/${PF}/examples"
+ doins datafiles/*.circ datafiles/*.load
+
+}