aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2011-07-11 13:23:57 +0200
committerHonza Macháček <Hloupy.Honza@centrum.cz>2011-07-11 13:23:57 +0200
commitbf9b631994cb55d61820c333061eb4d6047a866b (patch)
treed3d96e647afe558a625a149b7bf9a9814d5fa606 /sci-libs/bigdft/bigdft-1.2.0.2.ebuild
parentsci-biology/gbrowse-2.38: added URL to Bio::DB::Sam (diff)
downloadsci-bf9b631994cb55d61820c333061eb4d6047a866b.tar.gz
sci-bf9b631994cb55d61820c333061eb4d6047a866b.tar.bz2
sci-bf9b631994cb55d61820c333061eb4d6047a866b.zip
Restored the MPI support in sci-libs/bigdft-1.2.0.2, broken by the introduction of the fortran-2.eclass.
Diffstat (limited to 'sci-libs/bigdft/bigdft-1.2.0.2.ebuild')
-rw-r--r--sci-libs/bigdft/bigdft-1.2.0.2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sci-libs/bigdft/bigdft-1.2.0.2.ebuild b/sci-libs/bigdft/bigdft-1.2.0.2.ebuild
index c81e7303c..dc03955c7 100644
--- a/sci-libs/bigdft/bigdft-1.2.0.2.ebuild
+++ b/sci-libs/bigdft/bigdft-1.2.0.2.ebuild
@@ -46,13 +46,14 @@ src_prepare() {
}
src_configure() {
+ # fortran-2.eclass does not handle mpi wrappers
if use mpi; then
- MY_FC="mpif90"
- MY_CC="mpicc"
+ export FC="mpif90"
+ export CC="mpicc"
+ else
+ tc-export FC CC
fi
- tc-export FC CC
-
econf \
$(use_enable mpi) \
--enable-libpoissonsolver \