aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2007-08-16 16:00:47 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2007-08-16 16:00:47 +0000
commitc399feead1b8d9ea84e3940a60a02f6b056d5df5 (patch)
tree9c6487ff15eb20e050bd3959e766f0daa43f010f /sci-libs/blas-goto
parentadded new virtual blas, cblas and lapack (diff)
downloadsci-c399feead1b8d9ea84e3940a60a02f6b056d5df5.tar.gz
sci-c399feead1b8d9ea84e3940a60a02f6b056d5df5.tar.bz2
sci-c399feead1b8d9ea84e3940a60a02f6b056d5df5.zip
added many updates to blas/lapack packages
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@691 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs/blas-goto')
-rw-r--r--sci-libs/blas-goto/Manifest16
-rw-r--r--sci-libs/blas-goto/blas-goto-1.16.ebuild153
-rw-r--r--sci-libs/blas-goto/files/blas.pc.in12
-rw-r--r--sci-libs/blas-goto/files/digest-blas-goto-1.163
-rw-r--r--sci-libs/blas-goto/files/eselect.blas.goto4
5 files changed, 188 insertions, 0 deletions
diff --git a/sci-libs/blas-goto/Manifest b/sci-libs/blas-goto/Manifest
new file mode 100644
index 000000000..6fe2bfdc0
--- /dev/null
+++ b/sci-libs/blas-goto/Manifest
@@ -0,0 +1,16 @@
+AUX blas.pc.in 302 RMD160 4b7585f42152749a034ba17ec30f2c0afdfaa574 SHA1 465de61e8b57f509eb3268e71fe3f7dfc629a394 SHA256 b1135b177d91f06145e3a6d99ebdc53515a6446cc4d66ff4f6a9cc18a97875f8
+MD5 c937385edb7a826dc325c2a598870cbd files/blas.pc.in 302
+RMD160 4b7585f42152749a034ba17ec30f2c0afdfaa574 files/blas.pc.in 302
+SHA256 b1135b177d91f06145e3a6d99ebdc53515a6446cc4d66ff4f6a9cc18a97875f8 files/blas.pc.in 302
+AUX eselect.blas.goto 193 RMD160 b25ff1d0b37fed194afde473019706e6a9404718 SHA1 e4c78e7cace1d7144f1fc921a29d516b4234703d SHA256 33a9d0be6f400f792f744604afae7239b2d7392cc0e8cac758b53e695acc0802
+MD5 123cb7f07958ee38eebc1bfd038ad840 files/eselect.blas.goto 193
+RMD160 b25ff1d0b37fed194afde473019706e6a9404718 files/eselect.blas.goto 193
+SHA256 33a9d0be6f400f792f744604afae7239b2d7392cc0e8cac758b53e695acc0802 files/eselect.blas.goto 193
+DIST GotoBLAS-1.16.tar.gz 1783818 RMD160 416f905cb07a3eaf03c85f4660865393403fe398 SHA1 24e0bec6e06f400754ba4d6fc1950a1beb83c95b SHA256 4a490f86648aa26fa1e5bfe4569224c8146d0086db90280eeff279f92cb8cbe5
+EBUILD blas-goto-1.16.ebuild 3823 RMD160 eed05cba3b194f1ad0df291f9375ce1bb2be7d41 SHA1 c3db18d0782834f3cc87dc37b5e55501a02b5b07 SHA256 268dae63ed9f4c39a1993b6e002a345b28a594fea0e4f3c0623f3046316adefa
+MD5 d5904c6c1ae622bb9951f02c1e373792 blas-goto-1.16.ebuild 3823
+RMD160 eed05cba3b194f1ad0df291f9375ce1bb2be7d41 blas-goto-1.16.ebuild 3823
+SHA256 268dae63ed9f4c39a1993b6e002a345b28a594fea0e4f3c0623f3046316adefa blas-goto-1.16.ebuild 3823
+MD5 9a962a71f195f4c7e47eb6500e359bf7 files/digest-blas-goto-1.16 244
+RMD160 f746aa18c4fb25074c3bb812f2b6d9af23f207c8 files/digest-blas-goto-1.16 244
+SHA256 94fcc0a46d8b6bdc34b86b0262776addca8d14bc3b7a324f9e80d6445d166734 files/digest-blas-goto-1.16 244
diff --git a/sci-libs/blas-goto/blas-goto-1.16.ebuild b/sci-libs/blas-goto/blas-goto-1.16.ebuild
new file mode 100644
index 000000000..a15ba1b07
--- /dev/null
+++ b/sci-libs/blas-goto/blas-goto-1.16.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils fortran flag-o-matic toolchain-funcs
+
+MY_PN="GotoBLAS"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="The fastest implementations of the Basic Linear Algebra Subroutines"
+HOMEPAGE="http://www.tacc.utexas.edu/resources/software/software.php"
+SRC_URI="http://www.tacc.utexas.edu/resources/software/login/gotoblas/${MY_P}.tar.gz"
+LICENSE="tacc"
+SLOT="0"
+# See http://www.tacc.utexas.edu/resources/software/gotoblasfaq.php
+# for supported architectures
+KEYWORDS="~x86 ~amd64"
+IUSE="threads doc"
+RESTRICT="mirror"
+RDEPEND="app-admin/eselect-blas
+ dev-util/pkgconfig
+ doc? ( app-doc/blas-docs )"
+
+DEPEND="app-admin/eselect-blas
+ >=sys-devel/binutils-2.17"
+
+S="${WORKDIR}/${MY_PN}"
+FORTRAN="g77 gfortran ifc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Set up C compiler
+ if [[ $(tc-getCC) = *gcc ]]; then
+ C_COMPILER="GNU"
+ elif [[ $(tc-getCC) = icc ]]; then
+ C_COMPILER="INTEL"
+ else
+ die "tc-getCC() returned an invalid C compiler; valid are gcc or icc."
+ fi
+
+ # Set up FORTRAN 77 compiler
+ case ${FORTRANC} in
+ g77)
+ F_COMPILER="G77"
+ ;;
+ gfortran)
+ F_COMPILER="GFORTRAN"
+ F_LIB="-lgfortran"
+ ;;
+ ifc|ifort)
+ F_COMPILER="INTEL"
+ ;;
+ *)
+ die "fortran.eclass returned an invalid Fortran compiler \'${FORTRANC}\'; valid are ${FORTRAN}."
+ esac
+
+ # Fix shared lib build
+ sed -i \
+ -e "s:\(&& echo OK\):${F_LIB} \1:g" \
+ "${S}"/exports/Makefile \
+ || die "sed for shared libs failed"
+
+ # Set up compilers
+ sed -i \
+ -e "s:^# \(C_COMPILER =\) GNU:\1 ${C_COMPILER}:g" \
+ -e "s:^# \(F_COMPILER =\) G77:\1 ${F_COMPILER}:g" \
+ -e "s:^# \(SMP = 1\):\1:g" \
+ -e "s:\$(COMPILER_PREFIX)ar:$(tc-getAR):" \
+ -e "s:\$(COMPILER_PREFIX)as:$(tc-getAS):" \
+ -e "s:\$(COMPILER_PREFIX)ld:$(tc-getLD):" \
+ -e "s:\$(COMPILER_PREFIX)ranlib:$(tc-getRANLIB):" \
+ "${S}"/Makefile.rule \
+ || die "sed for setting up compilers failed"
+
+ # Threaded?
+ if use threads; then
+ sed -i \
+ -e "s:^# \(SMP = 1\):\1:g" \
+ "${S}"/Makefile.rule \
+ || die "sed for threads failed"
+ fi
+
+ # If you need a 64-bit integer interface, also do this for "INTERFACE64 = 1"
+ if use amd64; then
+ sed -i \
+ -e "s:^# \(BINARY64 = 1\):\1:g" \
+ "${S}"/Makefile.rule \
+ || die "sed for 64 binary failed"
+ fi
+
+ # Respect CFLAGS/FFLAGS
+ sed -i \
+ -e "/^COMMON_OPT += -O2$/d" \
+ -e "s:^\(CFLAGS[[:space:]]*=\):\1 ${CFLAGS}:" \
+ -e "s:^\(FFLAGS[[:space:]]*+=\):\1 ${FFLAGS}:" \
+ "${S}"/Makefile.rule \
+ || die "sed for flags failed"
+}
+
+src_compile() {
+
+ # Make static library
+ emake LDFLAGS=$(raw-ldflags) || die "emake failed"
+
+ # Make shared library
+ cd exports
+ emake so -j1 || die "emake failed"
+}
+
+src_test() {
+ cd test
+ emake || die "emake test failed"
+ make clean
+}
+
+src_install() {
+ local MAIN_DIR="/usr/$(get_libdir)/blas"
+ local DIR="${MAIN_DIR}/goto"
+
+ # dolib.so doesn't support our alternate locations
+ exeinto ${DIR}
+ doexe libgoto_*.so
+ dosym libgoto_*.so ${DIR}/libgoto.so
+ dosym libgoto_*.so ${DIR}/libgoto.so.0
+ dosym libgoto_*.so ${DIR}/libgoto.so.0.0.0
+
+ # dolib.a doesn't support our alternate locations
+ insinto ${DIR}
+ doins libgoto_*.a
+ dosym libgoto_*.a ${DIR}/libgoto.a
+
+ dodoc 01Readme.txt 03History.txt 04FAQ.txt
+
+ cp "${FILESDIR}"/blas.pc.in blas.pc
+ local extlibs=""
+ use threads && extlibs="${extlibs} -lpthread"
+ extlibs="${extlibs}"
+ sed -i \
+ -e "s/@LIBDIR@/$(get_libdir)/" \
+ -e "s/@PV@/${PV}/" \
+ -e "s/@EXTLIBS@/${extlibs}/" \
+ blas.pc || die "sed blas.pc failed"
+ insinto /usr/$(get_libdir)/blas/goto
+ doins blas.pc
+ eselect blas add $(get_libdir) "${FILESDIR}"/eselect.blas.goto goto
+}
+
+pkg_postinst() {
+ [[ -z "$(eselect blas show)" ]] && eselect blas set goto
+ elog "To use BLAS GOTO implementation, you have to issue (as root):"
+ elog "\n\teselect blas set goto\n"
+}
diff --git a/sci-libs/blas-goto/files/blas.pc.in b/sci-libs/blas-goto/files/blas.pc.in
new file mode 100644
index 000000000..fb802cfb0
--- /dev/null
+++ b/sci-libs/blas-goto/files/blas.pc.in
@@ -0,0 +1,12 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=/usr/@LIBDIR@
+includedir=${prefix}/include
+
+Name: blas
+Description: GOTO implementations of the F77 Basic Linear Algebra Subroutines
+Version: @PV@
+URL: http://www.tacc.utexas.edu/resources/software/software.php
+Libs: -L${libdir} -lblas
+Libs.private: @EXTLIBS@
+
diff --git a/sci-libs/blas-goto/files/digest-blas-goto-1.16 b/sci-libs/blas-goto/files/digest-blas-goto-1.16
new file mode 100644
index 000000000..4bcd0425d
--- /dev/null
+++ b/sci-libs/blas-goto/files/digest-blas-goto-1.16
@@ -0,0 +1,3 @@
+MD5 fe1489037a3c2d69e7d5b9a05f14bfa9 GotoBLAS-1.16.tar.gz 1783818
+RMD160 416f905cb07a3eaf03c85f4660865393403fe398 GotoBLAS-1.16.tar.gz 1783818
+SHA256 4a490f86648aa26fa1e5bfe4569224c8146d0086db90280eeff279f92cb8cbe5 GotoBLAS-1.16.tar.gz 1783818
diff --git a/sci-libs/blas-goto/files/eselect.blas.goto b/sci-libs/blas-goto/files/eselect.blas.goto
new file mode 100644
index 000000000..0097969eb
--- /dev/null
+++ b/sci-libs/blas-goto/files/eselect.blas.goto
@@ -0,0 +1,4 @@
+blas/goto/libgoto.so /usr/@LIBDIR@/libblas.so
+blas/goto/libgoto.so.0 /usr/@LIBDIR@/libblas.so.0
+blas/goto/libgoto.a /usr/@LIBDIR@/libblas.a
+../blas/goto/blas.pc /usr/@LIBDIR@/pkgconfig/blas.pc