aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2007-05-07 14:20:32 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2007-05-07 14:20:32 +0000
commit3172694fdd5283c5fcd12d895172e2d2065f137b (patch)
tree6af01e996194373144f6afdefedd1a4a151029ce /sci-libs/cfitsio/cfitsio-3.040.ebuild
parentAdded a check that, if guile is 1.8, it is emerged with +deprecated (diff)
downloadsci-3172694fdd5283c5fcd12d895172e2d2065f137b.tar.gz
sci-3172694fdd5283c5fcd12d895172e2d2065f137b.tar.bz2
sci-3172694fdd5283c5fcd12d895172e2d2065f137b.zip
sci-libs/cfitsio: Version bump
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@596 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs/cfitsio/cfitsio-3.040.ebuild')
-rw-r--r--sci-libs/cfitsio/cfitsio-3.040.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/cfitsio/cfitsio-3.040.ebuild b/sci-libs/cfitsio/cfitsio-3.040.ebuild
new file mode 100644
index 000000000..ec2dcf6de
--- /dev/null
+++ b/sci-libs/cfitsio/cfitsio-3.040.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit fortran autotools
+
+DESCRIPTION="C and Fortran library for manipulating FITS files"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html"
+SRC_URI="ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/${PN}${PV//.}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fortran"
+
+DEPEND="fortran? ( dev-lang/cfortran )"
+FORTRAN="gfortran g77 ifc"
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ use fortran && fortran_pkg_setup
+}
+
+src_unpack() {
+ if use fortran; then
+ fortran_src_unpack ${A}
+ export FC="${FORTRANC}"
+ sed -i \
+ -e 's:"cfortran.h":<cfortran.h>:' \
+ "${S}"/f77_wrap.h || die "sed failed"
+ else
+ unpack ${A}
+ fi
+ cd "${S}"
+ cp "${FILESDIR}"/${P}-Makefile.am Makefile.am
+ cp "${FILESDIR}"/${P}-configure.ac configure.ac
+ eautoreconf
+}
+
+src_test() {
+ make testprog
+ ./testprog > testprog.lis
+ diff testprog.lis testprog.out || die "test failed"
+ cmp testprog.fit testprog.std || die "failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc changes.txt README License.txt
+ insinto /usr/share/doc/${PF}
+ doins cookbook.{f,c}
+ use doc && dodoc *.ps
+}